openssh: adjust engine support to openssl 1.1.1 8272/head
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Thu, 21 Feb 2019 10:47:12 +0000 (07:47 -0300)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Tue, 2 Apr 2019 19:48:08 +0000 (16:48 -0300)
Openssl 1.1.1 package in openwrt enabled more than just the devcrypto
engine, so the engine support in openssh should be enabled when general
engine support is enabled in openssl.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
net/openssh/Makefile

index d71cee690345ae04619018138480eadeeffa9730..39b02758f084d5049ffb08f9c0c0fb0d42b51855 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
 PKG_VERSION:=7.9p1
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
@@ -180,7 +180,7 @@ CONFIGURE_ARGS += \
        --without-pam
 endif
 
-ifeq ($(CONFIG_OPENSSL_ENGINE_CRYPTO),y)
+ifeq ($(CONFIG_OPENSSL_ENGINE),y)
 CONFIGURE_ARGS+= \
        --with-ssl-engine
 endif