pypcap: fix compile error with the new libpcap
authorFelix Fietkau <nbd@openwrt.org>
Sun, 5 Jul 2009 13:14:28 +0000 (13:14 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 5 Jul 2009 13:14:28 +0000 (13:14 +0000)
SVN-Revision: 16691

lang/pypcap/Makefile

index ed7d0281d78ef3069764d706c831f54013c9cb9f..bbf1fc835672748958652284ca28c8662232d0c9 100644 (file)
@@ -33,6 +33,8 @@ define PyPackage/python-pcap/filespec
 +|$(PYTHON_PKG_DIR)/pcap.so
 endef
 
+TARGET_CFLAGS += -DHAVE_PCAP_FILE=1
+
 define Build/Compile
        $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \