acme: Not all fields should be mandatory in Luci
authorToke Høiland-Jørgensen <toke@toke.dk>
Wed, 27 Jun 2018 21:06:06 +0000 (23:06 +0200)
committerToke Høiland-Jørgensen <toke@toke.dk>
Wed, 27 Jun 2018 21:06:06 +0000 (23:06 +0200)
Fixes #6370.

Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
net/acme/Makefile
net/acme/files/acme-cbi.lua

index 205b5f122b97d984f2b00d3163ee7b61a40e031b..a6d618bed9facb2cc7aab8022ae9891493d7904b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=acme
 PKG_VERSION:=2.7.8
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=GPLv3
 
 PKG_SOURCE_PROTO:=git
index 264d335315f3f1a9f76e9ceb0c0ee7986d6617bf..193699cc398ac3e475118cb8155a8c1d5ddfccf9 100644 (file)
@@ -61,7 +61,7 @@ wr = cs:option(Value, "webroot", translate("Webroot directory"),
                translate("Webserver root directory. Set this to the webserver " ..
                          "document root to run Acme in webroot mode. The web " ..
                          "server must be accessible from the internet on port 80."))
-wr.rmempty = false
+wr.optional = true
 
 dom = cs:option(DynamicList, "domains", translate("Domain names"),
                 translate("Domain names to include in the certificate. " ..
@@ -75,7 +75,7 @@ dns = cs:option(Value, "dns", translate("DNS API"),
                           "In DNS mode, the domain name does not have to resolve to the router IP. " ..
                           "DNS mode is also the only mode that supports wildcard certificates. " ..
                           "Using this mode requires the acme-dnsapi package to be installed."))
-dns.rmempty = false
+dns.optional = true
 
 cred = cs:option(DynamicList, "credentials", translate("DNS API credentials"),
                  translate("The credentials for the DNS API mode selected above. " ..