kamailio-5.x: improve module depends
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 12:48:58 +0000 (13:48 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 12:49:01 +0000 (13:49 +0100)
Currently the Makefile pulls in depends even for packages which are not
selected. Fix this by prefixing the depends with the respective
PACKAGE_* item.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/kamailio-5.x/Makefile

index 9e9a825d8f93e2734538f205dc96f1299b6ec2b4..0640544d7b623a135ac13c2750c6ebf297fcbffa 100644 (file)
@@ -93,7 +93,7 @@ define BuildKamailio5Module
   define Package/kamailio5-mod-$(subst _,-,$(1))
     $$(call Package/kamailio5/Default)
     TITLE:=$(2) for Kamailio5
-    DEPENDS:=kamailio5 $(4)
+    DEPENDS:=kamailio5 $(patsubst +%,+PACKAGE_kamailio5-mod-$(subst _,-,$(1)):%,$(4))
   endef
 
   define Package/kamailio5-mod-$(subst _,-,$(1))/install