baresip: add patch to fix ld call
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 26 Nov 2017 22:03:15 +0000 (23:03 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 26 Nov 2017 22:03:17 +0000 (23:03 +0100)
ld expects '-shared' when called with '--export-dynamic'. Patch the
Makefile accordingly.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/baresip/patches/001-fix-linker-call.patch [new file with mode: 0644]

diff --git a/net/baresip/patches/001-fix-linker-call.patch b/net/baresip/patches/001-fix-linker-call.patch
new file mode 100644 (file)
index 0000000..0df5ced
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -199,9 +199,9 @@ libbaresip.pc:
+ $(BIN):       $(APP_OBJS)
+       @echo "  LD      $@"
+ ifneq ($(GPROF),)
+-      $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
++      $(HIDE)$(LD) $(LFLAGS) $(SH_LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
+ else
+-      $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ \
++      $(HIDE)$(LD) $(LFLAGS) $(SH_LFLAGS) $(APP_LFLAGS) $^ \
+               -L$(LIBRE_SO) -lre $(LIBS) -o $@
+ endif