Merge pull request #3244 from tsl0922/ttyd
authorTed Hess <thess@kitschensync.net>
Wed, 28 Sep 2016 00:41:07 +0000 (20:41 -0400)
committerGitHub <noreply@github.com>
Wed, 28 Sep 2016 00:41:07 +0000 (20:41 -0400)
ttyd: new package

utils/ttyd/Makefile [new file with mode: 0644]
utils/ttyd/files/ttyd.init [new file with mode: 0644]

diff --git a/utils/ttyd/Makefile b/utils/ttyd/Makefile
new file mode 100644 (file)
index 0000000..7bf743e
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2016 Shuanglei Tao <tsl0922@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ttyd
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://github.com/tsl0922/ttyd.git
+PKG_SOURCE_VERSION:=$(PKG_VERSION)
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+CMAKE_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/ttyd
+       SECTION:=utils
+       CATEGORY:=Utilities
+       TITLE:=Command-line tool for sharing terminal over the web
+       DEPENDS:=+openssl +libjson-c +libpthread +libwebsockets-openssl
+       URL:=https://github.com/tsl0922/ttyd
+       SUBMENU:=Terminal
+       MAINTAINER:=Shuanglei Tao <tsl0922@gmail.com>
+endef
+
+define Package/ttyd/description
+ttyd is a command-line tool for sharing terminal over the web.
+endef
+
+define Package/ttyd/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ttyd $(1)/usr/bin/
+
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ttyd.init $(1)/etc/init.d/ttyd
+endef
+
+$(eval $(call BuildPackage,ttyd))
diff --git a/utils/ttyd/files/ttyd.init b/utils/ttyd/files/ttyd.init
new file mode 100644 (file)
index 0000000..d8d6d10
--- /dev/null
@@ -0,0 +1,26 @@
+#!/bin/sh /etc/rc.common
+
+START=99
+SERVICE_WRITE_PID=1
+SERVICE_DAEMONIZE=1
+
+start() {
+       logger -t TTYD 'Starting ttyd service'
+       service_start /usr/bin/ttyd login
+       return 0
+}
+
+stop() {
+       if [ -n "`pidof ttyd`" ]; then
+               logger -t TTYD 'Shutting down ttyd service'
+               service_stop /usr/bin/ttyd
+       fi
+       return 0
+}
+
+restart() {
+       logger -t TTYD 'Restarting ttyd service'
+       stop
+       sleep 2 # give time to shutdown
+       start
+}