libshout: depend on both libvorbis and libvorbisidec (#8496)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 22 Dec 2010 10:08:10 +0000 (10:08 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 22 Dec 2010 10:08:10 +0000 (10:08 +0000)
SVN-Revision: 24792

libs/libshout/Makefile

index 9067d17391bd168a424eef27c462cbcea1736cd5..1072e918c2e1f48160bff239588b9f3ee093f495 100644 (file)
@@ -24,7 +24,7 @@ TARGET_CFLAGS += $(FPIC)
 
 define Package/libshout
   SECTION:=libs
-  DEPENDS:= +libspeex +libtheora +libvorbis
+  DEPENDS:= +libspeex +libtheora +libvorbis +libvorbisidec
   CATEGORY:=Libraries
   TITLE:=Library which can be used to write a source client like ices
   URL:=http://www.icecast.org/download.php
@@ -41,7 +41,7 @@ endef
 define Build/Configure
        $(call Build/Configure/Default, \
                VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/"\
-               VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis" \
+               VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis -lvorbisidec" \
                --enable-shared \
                --enable-static \
        )