python-cryptography: Update patch to disable Rust
authorJeffery To <jeffery.to@gmail.com>
Sat, 18 Feb 2023 10:24:43 +0000 (18:24 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 24 Apr 2023 08:18:14 +0000 (16:18 +0800)
This extends the patch to also apply for pyproject.toml-based builds.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-cryptography/patches/0004-disable-rust.patch

index 81c45a44df6eef26d9b7afb0a40e4add5cbd240f..bf3010bb03f7a24a62e6f652f12d24ad5b192415 100644 (file)
@@ -1,3 +1,13 @@
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -6,7 +6,6 @@ requires = [
+     "wheel",
+     # Must be kept in sync with the `setup_requirements` in `setup.py`
+     "cffi>=1.12; platform_python_implementation != 'PyPy'",
+-    "setuptools-rust>=0.11.4",
+ ]
+ build-backend = "setuptools.build_meta"
 --- a/setup.py
 +++ b/setup.py
 @@ -11,7 +11,7 @@ import sys