libev: Fix compatibility with libevent2 includes 2112/head
authorTed Hess <thess@kitschensync.net>
Fri, 11 Dec 2015 22:58:41 +0000 (17:58 -0500)
committerTed Hess <thess@kitschensync.net>
Fri, 11 Dec 2015 22:58:47 +0000 (17:58 -0500)
Packages building with libev and want to include event.h from libev
need to be modified to include ev_event_compat.h instead.

The are no known packages which need to be fixed at this time. The
normal include is ev.h for this package.

Signed-off-by: Ted Hess <thess@kitschensync.net>
libs/libev/Makefile

index 9f0dc5c89b9312fb1ded65ca5535a3faaa9d09a4..1cd08e49c06642a5d1f79a0f312c8020ca688759 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libev
 PKG_VERSION:=4.20
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://dist.schmorp.de/libev/Attic/
@@ -44,7 +44,9 @@ CONFIGURE_ARGS += \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/event.h $(1)/usr/include/ev_event_compat.h
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ev.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ev++.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libev.{a,so*} $(1)/usr/lib/
 endef