use 127.0.0.1 as dns server and point dnsmasq to /tmp/resolv.conf
authorFelix Fietkau <nbd@openwrt.org>
Tue, 25 Jul 2006 18:12:30 +0000 (18:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 25 Jul 2006 18:12:30 +0000 (18:12 +0000)
SVN-Revision: 4282

openwrt/package/base-files/Makefile
openwrt/package/base-files/default/etc/functions.sh
openwrt/package/base-files/default/etc/resolv.conf [new file with mode: 0644]
openwrt/package/dnsmasq/files/dnsmasq.conf

index 836dc5673f52c8a36c0783a22a187449de3490af..dfe7c38664d45db68997700e2154608c3901fc1e 100644 (file)
@@ -50,7 +50,6 @@ $(IPKG_BASE):
        mkdir -p $(IDIR_BASE)/usr/lib
        mkdir -p $(IDIR_BASE)/usr/bin
        mkdir -p $(IDIR_BASE)/www
-       ln -sf /tmp/resolv.conf $(IDIR_BASE)/etc/resolv.conf
        rm -f $(IDIR_BASE)/var
        ln -sf /tmp $(IDIR_BASE)/var
        -find $(IDIR_BASE) -type d -name CVS | xargs rm -rf
index 8072c9ac621cb4ed138e97620493dcd9cd76b6d2..966615b3508859595cdb5aa66821178fd6ca5c02 100755 (executable)
@@ -52,10 +52,10 @@ do_ifup() {
                        } done
                }
 
-               [ -f /etc/resolv.conf ] || {
-                       debug "# --- creating /etc/resolv.conf ---"
+               [ -f /tmp/resolv.conf ] || {
+                       debug "# --- creating /tmp/resolv.conf ---"
                        for dns in $(nvram get ${2}_dns); do
-                               echo "nameserver $dns" >> /etc/resolv.conf
+                               echo "nameserver $dns" >> /tmp/resolv.conf
                        done
                }
                
diff --git a/openwrt/package/base-files/default/etc/resolv.conf b/openwrt/package/base-files/default/etc/resolv.conf
new file mode 100644 (file)
index 0000000..9617eac
--- /dev/null
@@ -0,0 +1,2 @@
+nameserver 127.0.0.1
+search lan
index d4a9f082ca4635a25d9c4122a7956e72fea615a6..50ddb01e880f8cdf5617e80c4e97cd0430ae65bd 100644 (file)
@@ -9,6 +9,8 @@ local=/lan/
 domain=lan
 expand-hosts
 
+resolv-file=/tmp/resolv.conf
+
 # enable dhcp (start,end,netmask,leasetime)
 dhcp-authoritative
 #dhcp-range=192.168.1.100,192.168.1.250,255.255.255.0,12h