stunnel: Bump from 5.10 to 5.14 1115/head
authorMichael Haas <haas@computerlinguist.org>
Fri, 3 Apr 2015 08:16:27 +0000 (10:16 +0200)
committerMichael Haas <haas@computerlinguist.org>
Fri, 3 Apr 2015 08:20:18 +0000 (10:20 +0200)
Also refresh patches.

Signed-Off-By: Michael Haas <haas@computerlinguist.org>
net/stunnel/Makefile
net/stunnel/patches/010_fix_getnameinfo.patch

index 9238331d77fc6a9bb4ab75767350dd2a0f343a44..0b928b7f65191c77f22f903b24d60b5bdef5d7d4 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stunnel
-PKG_VERSION:=5.10
+PKG_VERSION:=5.14
 PKG_RELEASE:=1
 
 PKG_LICENSE:=GPL-2.0+
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=COPYING COPYRIGHT.GPL
 
 PKG_SOURCE_URL:=http://stunnel.cybermirror.org/archive/5.x/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=a0edda805eb7d6ea600a230fb0979ea1
+PKG_MD5SUM:=e716501960dc6856d80f92547298f724
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
index f0a9faa7b5095cba9cb9d02de643e16d9d8d9289..03acfafac3009b7d2b71cf88162c551dc87936f6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/prototypes.h
 +++ b/src/prototypes.h
-@@ -559,7 +559,7 @@ extern GETNAMEINFO s_getnameinfo;
+@@ -590,7 +590,7 @@ extern GETNAMEINFO s_getnameinfo;
  
  #endif /* USE_WIN32 */
  
@@ -11,7 +11,7 @@
  
 --- a/src/resolver.c
 +++ b/src/resolver.c
-@@ -535,8 +535,9 @@ const char *s_gai_strerror(int err) {
+@@ -538,8 +538,9 @@ const char *s_gai_strerror(int err) {
  /* implementation is limited to functionality needed by stunnel */
  
  #ifndef HAVE_GETNAMEINFO