iotivity: make logging configurable 3800/head
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 8 Jan 2017 21:13:19 +0000 (22:13 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 9 Jan 2017 22:31:22 +0000 (23:31 +0100)
Before this change logging was always activated and then IoTivity wrote
a lot of debug messages. Make it now configurable.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
net/iotivity/Makefile

index bb67e19e4a480f6829dd87286e92f03567917142..e1491f7794242bccc19f3ae7ab1ab13c427dd2db 100644 (file)
@@ -66,6 +66,12 @@ define Package/iotivity/config
                help
                  Activate security support.
 
+       config PACKAGE_iotivity_LOGGING
+               bool "IoTivity with logging support"
+               default y
+               help
+                 Activate logging support.
+                 This will make IoTivity write a lot of log messages to stdout.
   endif
 endef
 
@@ -178,7 +184,6 @@ SCONS_OPTIONS += \
        TARGET_TRANSPORT=IP \
        TARGET_ARCH=$(ARCH) \
        STAGING_DIR=$(STAGING_DIR) \
-       LOGGING=true \
        WITH_ENV=true \
        octbstack oc \
        $(if $(CONFIG_PACKAGE_iotivity-oic-middle),examples) \
@@ -203,6 +208,10 @@ else
   SCONS_OPTIONS += SECURED=0
 endif
 
+ifeq ($(CONFIG_PACKAGE_iotivity_LOGGING),y)
+  SCONS_OPTIONS += LOGGING=true
+endif
+
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
   SCONS_OPTIONS += VERBOSE=true
 endif