[packages] libpng: update to 1.2.44, change InstallDev to install libpng*-config...
authorNicolas Thill <nico@openwrt.org>
Tue, 13 Jul 2010 03:11:20 +0000 (03:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 13 Jul 2010 03:11:20 +0000 (03:11 +0000)
SVN-Revision: 22160

libs/libpng/Makefile
libs/libpng/patches/100-config_fix.patch

index 753d2ed1dad7d65a27f538313f39217b66384080..786ac2e3e71a0b57aa23d1d3ca4073080ab77016 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpng
-PKG_VERSION:=1.2.41
+PKG_VERSION:=1.2.44
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/libpng
-PKG_MD5SUM:=2faa7f8d81e6a35beb991cb75edbf056
+PKG_MD5SUM:=e3ac7879d62ad166a6f0c7441390d12b
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -21,8 +21,6 @@ PKG_INSTALL:=1
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
-TARGET_CFLAGS += $(FPIC)
-
 define Package/libpng
   SECTION:=libs
   CATEGORY:=Libraries
@@ -31,25 +29,29 @@ define Package/libpng
   URL:=http://www.libpng.org/pub/png/libpng.html
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --with-zlib="$(STAGING_DIR)/usr" \
-       )
-endef
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(2)/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libpng{,12}-config $(2)/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/libpng{,12}-config $(1)/usr/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(1)/usr/bin/libpng{,12}-config
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/png{,conf}.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libpng12 $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpng{,12}.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpng{,12}.{a,la,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libpng{,12}.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,^[ILR]_opts=".\+",,g' $(2)/bin/libpng*-config
+       $(INSTALL_DIR) $(2)/bin
+       for f in libpng{,12}-config; do \
+               $(LN) ../../usr/bin/$$$$f $(2)/bin/ ; \
+       done
 endef
 
 define Package/libpng/install
index e0ed94dca89263ed36c8ced7e2e8e2d2ce3b1ada..3cb6d8a1f635c20c935265ea857db0aa34cc21cc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/scripts/libpng-config-body.in
 +++ b/scripts/libpng-config-body.in
-@@ -83,6 +83,7 @@
+@@ -83,6 +83,7 @@ while test $# -gt 0; do
  
      --static)
          R_opts=""
@@ -8,12 +8,3 @@
          ;;
  
      *)
---- a/scripts/libpng.pc.in
-+++ b/scripts/libpng.pc.in
-@@ -6,5 +6,5 @@
- Name: libpng
- Description: Loads and saves PNG files
- Version: 1.2.41
--Libs: -L${libdir} -lpng12
-+Libs: -lpng12
- Cflags: -I${includedir}