unbound: Use INSTALL_BIN/DATA for installation
authorMichael Hanselmann <public@hansmi.ch>
Fri, 10 Jun 2016 22:02:53 +0000 (00:02 +0200)
committerMichael Hanselmann <public@hansmi.ch>
Tue, 14 Jun 2016 20:09:31 +0000 (22:09 +0200)
The commands aliased by $(INSTALL_BIN) and $(INSTALL_DATA) set good
permissions, unlike a raw file copy.

Signed-off-by: Michael Hanselmann <public@hansmi.ch>
net/unbound/Makefile

index 67dcb65a39a8de8d3f2e51a987675ce950071d81..ba1e51565820449bd52188127cc5ec5a2e00d4d4 100644 (file)
@@ -122,14 +122,14 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/unbound.h $(1)/usr/include/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/unbound.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunbound.{so*,a,la} $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libunbound.{so*,a,la} $(1)/usr/lib/
 endef
 
 define Package/unbound/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) \
+       $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/sbin/unbound \
                $(PKG_INSTALL_DIR)/usr/sbin/unbound-checkconf \
                $(1)/usr/sbin/
@@ -144,27 +144,27 @@ endef
 
 define Package/unbound-anchor/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/unbound-anchor $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/unbound-anchor $(1)/usr/sbin/
 endef
 
 define Package/unbound-control/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/unbound-control $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/unbound-control $(1)/usr/sbin/
 endef
 
 define Package/unbound-control-setup/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/unbound-control-setup $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/unbound-control-setup $(1)/usr/sbin/
 endef
 
 define Package/unbound-host/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/unbound-host $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/unbound-host $(1)/usr/sbin/
 endef
 
 define Package/libunbound/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunbound.so.* $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libunbound.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,unbound))