freeswitch-stable: don't force disable on install
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 12 Nov 2018 21:04:16 +0000 (22:04 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Mon, 12 Nov 2018 21:06:55 +0000 (22:06 +0100)
Don't force freeswitch to off during postinstall. It's not common
practice (anywhere) and it may be confusing.

Add a link to the Wiki, too, and bump the revision.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/freeswitch-stable/Makefile

index 0dd4dcffaf2e3a8b9f99d4ff72bae083bcb7dd28..766c457fb39fd2e7e412e7f6bccae8c533d39557 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PRG_NAME:=freeswitch
 PKG_NAME:=$(PRG_NAME)-stable
 PKG_VERSION:=1.8.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
 
 PKG_SOURCE:=$(PRG_NAME)-$(PKG_VERSION).tar.xz
@@ -428,16 +428,14 @@ endef
 define Package/$(PKG_NAME)/postinst
 #!/bin/sh
 if [ -z "$${IPKG_INSTROOT}" ]; then
-  # Prevent $(PRG_NAME) from auto-starting after an upgrade. The modules may
-  # not be upgraded yet and the user configuration may need a revision.
-  uci set freeswitch.general.enabled=0
-  uci commit freeswitch
-
   echo
   echo "o-------------------------------------------------------------------o"
   echo "| FreeSWITCH note                                                   |"
   echo "o-------------------------------------------------------------------o"
   echo "| Edit /etc/config/freeswitch to change basic init configuration.   |"
+  echo "|                                                                   |"
+  echo "| Also visit the Wiki at:                                           |"
+  echo "| https://openwrt.org/docs/guide-user/services/voip/freeswitch      |"
   echo "o-------------------------------------------------------------=^_^=-o"
   echo
   [ -f /etc/hotplug.d/iface/99-freeswitch ] && {