bcm53xx: enable Linksys EA6300 & EA9200 builds
authorRafał Miłecki <rafal@milecki.pl>
Mon, 18 Oct 2021 13:59:43 +0000 (15:59 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Mon, 13 Dec 2021 13:01:14 +0000 (14:01 +0100)
Both should be supported since:
1. Adding NVMEM driver for NVRAM
2. Using NVRAM info for determining active firmware partition

Linksys EA9500 uses very similar design and works fine.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit 287257d676b1120f388120f1dc259e4eefd3b163)

target/linux/bcm53xx/image/Makefile

index 95807232733ad473771733c621fb94a74d0e757f..f2c145a375f5c2aa62c18e355d601b863caa981f 100644 (file)
@@ -242,13 +242,11 @@ define Device/dlink_dir-885l
 endef
 TARGET_DEVICES += dlink_dir-885l
 
-# Linksys devices are disabled due to problem with 2 TRX partitions
 define Device/linksys_ea6300-v1
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := EA6300
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
-  BROKEN := y
 endef
 TARGET_DEVICES += linksys_ea6300-v1
 
@@ -265,7 +263,6 @@ define Device/linksys_ea9200
   DEVICE_MODEL := EA9200
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
-  BROKEN := y
 endef
 TARGET_DEVICES += linksys_ea9200