ruby: Fix build dependency of gmp/host
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>
Wed, 20 Aug 2014 03:33:29 +0000 (00:33 -0300)
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>
Wed, 20 Aug 2014 03:33:29 +0000 (00:33 -0300)
libgmp.so is needed for miniruby, that is compiled in host.
Using PKG_BUILD_DEPENDS=gmp/host eventually compiled gmp/host
before ruby/host. However, when this did not happened, build
failed. Using HOST_BUILD_DEPENDS=gmp/host seems to be the
correct way to require it.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
lang/ruby/Makefile

index a37d89f158d0d18d851fae3fd2da5420100087c9..661b3e725b12ac23ad237983ecde38536bb8e4c9 100644 (file)
@@ -27,11 +27,13 @@ PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
 PKG_LICENSE:=BSD-2-Clause
 PKG_LICENSE_FILE:=COPYING
 
-PKG_BUILD_DEPENDS:=ruby/host gmp/host
+PKG_BUILD_DEPENDS:=ruby/host
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 PKG_FIXUP:=autoreconf
 
+HOST_BUILD_DEPENDS:=gmp/host
+
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk