dhtd: update to 0.2.4 22706/head
authorMoritz Warning <moritzwarning@web.de>
Sun, 19 Nov 2023 15:48:00 +0000 (16:48 +0100)
committerMoritz Warning <moritzwarning@web.de>
Tue, 21 Nov 2023 11:55:04 +0000 (12:55 +0100)
* add option to execute a script for each result

Signed-off-by: Moritz Warning <moritzwarning@web.de>
net/dhtd/Makefile
net/dhtd/files/dhtd.config
net/dhtd/files/dhtd.init

index bb09f8b4ac6e5c037e34f55a724c8edcd4c9be33..8cc8b22d5f28bf6c5dba2b75a1d9f3789358cada 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dhtd
-PKG_VERSION:=0.2.1
+PKG_VERSION:=0.2.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/mwarning/dhtd/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=65d2e0d6a3648fe3619d9fa4bef34a76c22577b7fe3fe460f96ac10510c3f06a
+PKG_HASH:=0f35cd0016689682b277f9769ec1e95c3c1321479cedc9727abc0bc91a0427d5
 
 PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
 PKG_LICENSE:=MIT
index 60b15b8a60917e25335c62ada3b98072f448b40a..e933e65b570d72eef38084d52026f5bc47f90af3 100644 (file)
@@ -15,6 +15,9 @@ config dhtd
        list peer 'bttracker.debian.org:6881'
        list peer 'router.bittorrent.com:6881'
 
+## Execute a script for each result
+#      option execute '/root/on_result.sh'
+
 ## Bind the DHT to this port.
 #      option port '6881'
 
index 3cd7970573aa5d008e3b2ce888f1441b0aedf6ff..a3b1552987ebcac1bd55f34baf3f6ded245114bb 100755 (executable)
@@ -54,7 +54,7 @@ start_instance() {
 
        OPTS=""
 
-       append_opts "$cfg" verbosity peerfile port
+       append_opts "$cfg" verbosity peerfile port execute
 
        config_get ifname "$cfg" "ifname"
        if network_get_device IFNAME "$ifname";then