xl2tpd: don't let xl2tpd handle redial
authorDaniel Golle <daniel@makrotopia.org>
Fri, 5 Jun 2015 12:04:57 +0000 (14:04 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 5 Jun 2015 12:53:36 +0000 (14:53 +0200)
netifd is taking care of that already.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
net/xl2tpd/Makefile
net/xl2tpd/files/l2tp.sh

index c3582bef7e3c1b69b65ec19b2cd47330e1b700e4..cba7bf03f2cb824599c0c96378b4f1e350643c18 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xl2tpd
 PKG_VERSION:=1.3.7pre20150524
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=LICENSE
index 0748654a7031cd4f5a5bef3e037cd4eff2b42a41..d4a6505b96bb64d4212e769a2c1bd1ed919252d1 100644 (file)
@@ -86,7 +86,7 @@ proto_l2tp_setup() {
        echo "${ipv6:++ipv6} ${pppd_options}" >> "${optfile}"
        echo "${mtu:+mtu $mtu mru $mtu}" >> "${optfile}"
 
-       xl2tpd-control add l2tp-${interface} pppoptfile=${optfile} lns=${server} redial=yes redial timeout=20 || {
+       xl2tpd-control add l2tp-${interface} pppoptfile=${optfile} lns=${server} timeout=20 || {
                echo "xl2tpd-control: Add l2tp-$interface failed" >&2
                proto_setup_failed "$interface"
                exit 1