kernel: bump 5.10 to 5.10.152
authorJohn Audia <therealgraysky@proton.me>
Sun, 30 Oct 2022 12:32:36 +0000 (08:32 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 1 Nov 2022 12:56:11 +0000 (13:56 +0100)
All patches automatically rebased.

Signed-off-by: John Audia <therealgraysky@proton.me>
[Add CONFIG_ARM64_ERRATUM_1742098 to config]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 52400e167d83bd0bfc40394f9383529212b545ad)

include/kernel-5.10
target/linux/bcm27xx/patches-5.10/950-0046-MMC-added-alternative-MMC-driver.patch
target/linux/bcm27xx/patches-5.10/950-0162-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch
target/linux/bcm27xx/patches-5.10/950-0192-Kbuild-Allow-.dtbo-overlays-to-be-built-adjust.patch
target/linux/generic/config-5.10
target/linux/generic/hack-5.10/660-fq_codel_defaults.patch
target/linux/ipq806x/patches-5.10/093-drivers-cpufreq-qcom-cpufreq-nvmem-support-specific-.patch
target/linux/rockchip/armv8/config-5.10

index 7a588022b535f81e6ff3b9bd89ca4d55f672e6f9..f4cdfe5faa50acaf8dfe81e387d1ee143711f4ba 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .151
-LINUX_KERNEL_HASH-5.10.151 = dd8d6d0b0dad2be98f5f07bcd4cf7780a60a7de6367fdd2f5cd8f48dabeed1fa
+LINUX_VERSION-5.10 = .152
+LINUX_KERNEL_HASH-5.10.152 = fa0b5c83a4ebfda9f0a52cc693646eb6c24dbade6c37ee2d18b66ee2df15d8a6
index 0644dd42741f66844f0eb75438f9f9c6fd76aaed..cc56cff24f45aef53c6774f4021fe863f76e5af2 100644 (file)
@@ -221,7 +221,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  static inline int mmc_blk_part_switch(struct mmc_card *card,
                                      unsigned int part_type);
  static void mmc_blk_rw_rq_prep(struct mmc_queue_req *mqrq,
-@@ -2896,6 +2903,7 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2901,6 +2908,7 @@ static int mmc_blk_probe(struct mmc_card
  {
        struct mmc_blk_data *md, *part_md;
        char cap_str[10];
@@ -229,7 +229,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  
        /*
         * Check that the card supports the command class(es) we need.
-@@ -2903,7 +2911,16 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2908,7 +2916,16 @@ static int mmc_blk_probe(struct mmc_card
        if (!(card->csd.cmdclass & CCC_BLOCK_READ))
                return -ENODEV;
  
@@ -247,7 +247,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  
        card->complete_wq = alloc_workqueue("mmc_complete",
                                        WQ_MEM_RECLAIM | WQ_HIGHPRI, 0);
-@@ -2918,9 +2935,14 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2923,9 +2940,14 @@ static int mmc_blk_probe(struct mmc_card
  
        string_get_size((u64)get_capacity(md->disk), 512, STRING_UNITS_2,
                        cap_str, sizeof(cap_str));
@@ -278,9 +278,9 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  }
 --- a/drivers/mmc/core/quirks.h
 +++ b/drivers/mmc/core/quirks.h
-@@ -99,6 +99,14 @@ static const struct mmc_fixup __maybe_un
-       MMC_FIXUP("V10016", CID_MANFID_KINGSTON, CID_OEMID_ANY, add_quirk_mmc,
-                 MMC_QUIRK_TRIM_BROKEN),
+@@ -105,6 +105,14 @@ static const struct mmc_fixup __maybe_un
+       MMC_FIXUP(CID_NAME_ANY, CID_MANFID_SANDISK_SD, 0x5344, add_quirk_sd,
+                 MMC_QUIRK_BROKEN_SD_DISCARD),
  
 +      /*
 +       *  On some Kingston SD cards, multiple erases of less than 64
@@ -1922,9 +1922,9 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
 +MODULE_AUTHOR("Gellert Weisz");
 --- a/include/linux/mmc/card.h
 +++ b/include/linux/mmc/card.h
-@@ -271,6 +271,8 @@ struct mmc_card {
- #define MMC_QUIRK_TRIM_BROKEN (1<<12)         /* Skip trim */
+@@ -272,6 +272,8 @@ struct mmc_card {
  #define MMC_QUIRK_BROKEN_HPI  (1<<13)         /* Disable broken HPI support */
+ #define MMC_QUIRK_BROKEN_SD_DISCARD   (1<<14) /* Disable broken SD discard support */
  
 +#define MMC_QUIRK_ERASE_BROKEN        (1<<31)         /* Skip erase */
 +
index 9c8acd8b250618a43cad267d8e5a431387e4159f..0506bc26a849c9071d116f97b3206edd125e7b45 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1367,6 +1367,9 @@ ifneq ($(dtstree),)
+@@ -1369,6 +1369,9 @@ ifneq ($(dtstree),)
  %.dtb: include/config/kernel.release scripts_dtc
        $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
  
index a1f97539a32573c098d98ed13e0f18d8dcc5d43a..1a961ab45b5a0b72eddee57b99cd6db29d5f26e7 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Nataliya Korovkina <malus.brandywine@gmail.com>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1367,7 +1367,7 @@ ifneq ($(dtstree),)
+@@ -1369,7 +1369,7 @@ ifneq ($(dtstree),)
  %.dtb: include/config/kernel.release scripts_dtc
        $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
  
index 6fa7394201375a44bc630db570e869e9b6d28743..5023b2f8108c4c68f8e875bb0a2977a0090f7b5e 100644 (file)
@@ -321,6 +321,7 @@ CONFIG_ARCH_MMAP_RND_COMPAT_BITS_MIN=8
 # CONFIG_ARM64_ERRATUM_1508412 is not set
 # CONFIG_ARM64_ERRATUM_1530923 is not set
 # CONFIG_ARM64_ERRATUM_1542419 is not set
+# CONFIG_ARM64_ERRATUM_1742098 is not set
 # CONFIG_ARM64_ERRATUM_819472 is not set
 # CONFIG_ARM64_ERRATUM_824069 is not set
 # CONFIG_ARM64_ERRATUM_826319 is not set
index 5541c0bc89ee1b2b533ab4c19dfa7709d92d9a4e..a57a045f4a838285b8826dad55913d628f0f13a4 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/sched/sch_fq_codel.c
 +++ b/net/sched/sch_fq_codel.c
-@@ -469,7 +469,11 @@ static int fq_codel_init(struct Qdisc *s
+@@ -467,7 +467,11 @@ static int fq_codel_init(struct Qdisc *s
  
        sch->limit = 10*1024;
        q->flows_cnt = 1024;
index 19c3d096c416f9362ee41a1cabb81a895a65d54d..8a25b17a192ab2de1f2155a3561bd3954c845875 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  };
  
  struct qcom_cpufreq_drv {
-@@ -250,6 +251,7 @@ static const struct qcom_cpufreq_match_d
+@@ -253,6 +254,7 @@ static const struct qcom_cpufreq_match_d
  
  static const struct qcom_cpufreq_match_data match_data_krait = {
        .get_version = qcom_cpufreq_krait_name_version,
@@ -29,7 +29,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  };
  
  static const char *qcs404_genpd_names[] = { "cpr", NULL };
-@@ -385,6 +387,19 @@ static int qcom_cpufreq_probe(struct pla
+@@ -389,6 +391,19 @@ static int qcom_cpufreq_probe(struct pla
                }
        }
  
index d1e5d7385032f4bac6591a2f021d380b7646e2f2..1e9b1777d8b38267865f4a682e1cd48005a3c563 100644 (file)
@@ -19,6 +19,7 @@ CONFIG_ARM64=y
 CONFIG_ARM64_4K_PAGES=y
 CONFIG_ARM64_CNP=y
 CONFIG_ARM64_CRYPTO=y
+CONFIG_ARM64_ERRATUM_1742098=y
 CONFIG_ARM64_ERRATUM_819472=y
 CONFIG_ARM64_ERRATUM_824069=y
 CONFIG_ARM64_ERRATUM_826319=y