perl: Enable threading in host-perl as well if threading is selected
authorMarcel Denia <naoir@gmx.net>
Sat, 2 May 2015 14:08:00 +0000 (16:08 +0200)
committerMarcel Denia <naoir@gmx.net>
Wed, 27 May 2015 00:03:56 +0000 (02:03 +0200)
While host-perl only exists to run build scripts(and thus, should have
no influence on built packages at all), most packages depend heavily on the
feature set of the perl installation that ran their configuration scripts.
This change makes them see that threading support is enabled(if it actually
is selected).

We can't use configuration symbol overrides for this one, as they are
visible to host-perl as well. Using overrides would make it act as if it
had threading support enabled without actually having it.

Signed-off-by: Marcel Denia <naoir@gmx.net>
lang/perl/Makefile

index abd327f6200382093f4bf14529dbf84eefc25c1e..0365ffcff509b40dbfc2a1d01a501f9299366c4f 100644 (file)
@@ -94,7 +94,7 @@ endef
 
 # Static host perl
 define Host/Configure
-       ( cd $(HOST_BUILD_DIR); ./Configure -der -Uusedl -Duserelocatableinc -Dprefix=$(HOST_PERL_PREFIX) )
+       ( cd $(HOST_BUILD_DIR); ./Configure -der -Uusedl -Duserelocatableinc -Dprefix=$(HOST_PERL_PREFIX) $(if $(CONFIG_PERL_THREADS),-Dusethreads,))
 endef
 
 define Host/Install