libplist: Several fixes 10785/head
authorRosen Penev <rosenp@gmail.com>
Mon, 16 Dec 2019 20:42:45 +0000 (12:42 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 16 Dec 2019 20:54:06 +0000 (12:54 -0800)
Add myself as maintainer.

Add PKG_CPE_ID.

Switch to submenu for easier readability.

Change libplist-utils name to the utility.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libplist/Makefile

index 0f67a3e0b0e491c77ba88249908cbe8770a58e47..b198f98d63651104ce8aca15070b3a15a4168be0 100644 (file)
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libplist
 PKG_SOURCE_VERSION:=2.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/libimobiledevice/libplist
 PKG_MIRROR_HASH:=452ef5d6e87461a8b7a47a2274878cf200ccf480b4e81924f22ec1c445e353d0
 
-PKG_MAINTAINER:=
+PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
+PKG_CPE_ID:=cpe:/a:libimobiledevice:libplist
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
@@ -27,6 +28,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libplist/Default
   TITLE:=Apple property list
   URL:=https://www.libimobiledevice.org/
+  SUBMENU:=libimobiledevice
 endef
 
 define Package/libplist/Default/description
@@ -62,7 +64,7 @@ define Package/libplistcxx/description
   This package contains the libplist C++ shared library.
 endef
 
-define Package/libplist-utils
+define Package/plistutil
   $(call Package/libplist/Default)
   SECTION:=utils
   CATEGORY:=Utilities
@@ -72,7 +74,7 @@ define Package/libplist-utils
   LICENSE_FILES:=COPYING
 endef
 
-define Package/libplist-utils/description
+define Package/plistutil/description
   $(call Package/libplist/Default/description)
   This package contains the libplist utilities.
 endef
@@ -103,11 +105,11 @@ define Package/libplistcxx/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist++.so.* $(1)/usr/lib/
 endef
 
-define Package/libplist-utils/install
+define Package/plistutil/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/plistutil $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libplist))
 $(eval $(call BuildPackage,libplistcxx))
-$(eval $(call BuildPackage,libplist-utils))
+$(eval $(call BuildPackage,plistutil))