[packages_10.03.2] bandwidthd: merge r28946, r29199
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:41:38 +0000 (16:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:41:38 +0000 (16:41 +0000)
SVN-Revision: 30288

utils/bandwidthd/Makefile
utils/bandwidthd/files/bandwidthd.init

index 3121c68d073dea0fb63a7817037785cba14fa56f..3ae7d51cdb33d2152b5ba7f328dc8fd70ff848a1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bandwidthd
 PKG_VERSION:=2.0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/bandwidthd
@@ -53,4 +53,8 @@ define Package/bandwidthd/install
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/htdocs/logo.gif $(1)/www/
 endef
 
+define Package/bandwidthd/conffiles
+/etc/config/bandwidthd
+endef
+
 $(eval $(call BuildPackage,bandwidthd))
index 3b3819ddd4ee67a819c916706ad3fae33d018da7..6483daa2c00b97f7ca7927cea5d6ec88768229a6 100644 (file)
@@ -1,5 +1,6 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
+
 START=99
 
 config_cb() {
@@ -79,9 +80,9 @@ start() {
                unset conffile
        done
        cd /
-       bandwidthd
+       service_start /usr/sbin/bandwidthd
 }
 
 stop() {
-       killall bandwidthd
+       service_stop /usr/sbin/bandwidthd
 }