transmission: fix command param issue and use default respawn settings 10094/head
authorRichard Yu <yurichard3839@gmail.com>
Fri, 27 Sep 2019 10:07:04 +0000 (18:07 +0800)
committerRichard Yu <yurichard3839@gmail.com>
Fri, 27 Sep 2019 10:17:02 +0000 (18:17 +0800)
Signed-off-by: Richard Yu <yurichard3839@gmail.com>
net/transmission/Makefile
net/transmission/files/transmission.init

index 23efd920b68f2cd17922b9e1112212667067ca62..b78db281e63eb050c56581afffb7c04c4f4cae75 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
 PKG_VERSION:=2.94
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
index afeb651a895fff2bebc70bc576b0d346e0b1ff1c..1d57db5e629ab42188dfe1fee45f4ff2288e7596 100644 (file)
@@ -114,12 +114,12 @@ transmission() {
 
        procd_open_instance
        procd_set_param command "/usr/bin/transmission-daemon"
-       procd_append_param command "-f --log-error -g $config_dir"
+       procd_append_param command -f --log-error -g "$config_dir"
        procd_set_param user "$user"
        procd_set_param group "$group"
        procd_set_param nice "$nice"
        procd_set_param stderr 1
-       procd_set_param respawn retry=60
+       procd_set_param respawn
 
        if [ -z "$USE" ]; then
                procd_set_param limits core="0 0"