grep: update to 3.8
authorNick Hainke <vincent@systemli.org>
Sat, 10 Sep 2022 06:20:17 +0000 (08:20 +0200)
committerRosen Penev <rosenp@gmail.com>
Sat, 17 Sep 2022 19:56:09 +0000 (12:56 -0700)
Manually refresh:
- ppc-musl.patch

Release Notes:
https://lists.gnu.org/archive/html/info-gnu/2022-09/msg00001.html

Signed-off-by: Nick Hainke <vincent@systemli.org>
utils/grep/Makefile
utils/grep/patches/ppc-musl.patch

index 55190b1b87bbbacb26311612562b0b3c261adb65..6096adaf3f3e7262bf2878d14c4a7a00c3dbc35d 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=grep
-PKG_VERSION:=3.7
-PKG_RELEASE:=2
+PKG_VERSION:=3.8
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/grep
-PKG_HASH:=5c10da312460aec721984d5d83246d24520ec438dd48d7ab5a05dbc0d6d6823c
+PKG_HASH:=498d7cc1b4fb081904d87343febb73475cf771e424fb7e6141aff66013abc382
 
 PKG_MAINTAINER:=Julen Landa Alustiza <julen@zokormazo.info>
 PKG_LICENSE:=GPL-3.0-or-later
index 45c79eb0494b35f41b5abecf3ee9d9cd6c7315d5..aeb026689d0e18b0ea54beedee287edd58dcb77c 100644 (file)
@@ -1,15 +1,15 @@
 https://github.com/void-linux/void-packages/commit/0d9556b8593d6e67027fb1c83d176b7f899547e5
 --- a/lib/sigsegv.c
 +++ b/lib/sigsegv.c
-@@ -221,8 +221,10 @@ int libsigsegv_version = LIBSIGSEGV_VERS
- /* both should be equivalent */
- #   if 0
- #    define SIGSEGV_FAULT_STACKPOINTER  ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
--#   else
-+#   elif defined(__GLIBC__)
- #    define SIGSEGV_FAULT_STACKPOINTER  ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
-+#   else
+@@ -246,8 +246,10 @@ int libsigsegv_version = LIBSIGSEGV_VERS
+ /* Because of the union, both definitions should be equivalent.  */
+ #    if 0
+ #     define SIGSEGV_FAULT_STACKPOINTER  ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
+-#    else
++#    elif defined(__GLIBC__)
+ #     define SIGSEGV_FAULT_STACKPOINTER  ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
++#    else
 +#    define SIGSEGV_FAULT_STACKPOINTER  ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ #    endif
  #   endif
  #  endif