mdnsresponder: Fix compilation with uClibc-ng 9277/head
authorRosen Penev <rosenp@gmail.com>
Wed, 19 Jun 2019 21:54:19 +0000 (14:54 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 19 Jun 2019 21:54:19 +0000 (14:54 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/mdnsresponder/Makefile
net/mdnsresponder/patches/010-uclibc.patch [new file with mode: 0644]

index e209b8ff7eba9fe92e3456b4bd3fc52256cb50f9..6cb5ebd4b9b4ecdc91ada5850783104fe55432f5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mDNSResponder
 PKG_VERSION:=IETF104
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://opensource.apple.com/tarballs/mDNSResponder/IETF/
diff --git a/net/mdnsresponder/patches/010-uclibc.patch b/net/mdnsresponder/patches/010-uclibc.patch
new file mode 100644 (file)
index 0000000..a4d1308
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/mDNSShared/PlatformCommon.c
++++ b/mDNSShared/PlatformCommon.c
+@@ -43,6 +43,10 @@
+ typedef unsigned int socklen_t;
+ #endif
++#ifndef TCP_NOTSENT_LOWAT
++#define TCP_NOTSENT_LOWAT 25
++#endif
++
+ #if MDNS_MALLOC_DEBUGGING
+ // We ONLY want this for malloc debugging--on a running production system we want to deal with
+ // malloc failures, not just die.   There is a small performance penalty for enabling these options