Update l7-protocols to 2008-04-23 (#3630)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 14:05:03 +0000 (14:05 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 14:05:03 +0000 (14:05 +0000)
SVN-Revision: 11703

net/l7-protocols/Makefile
net/l7-protocols/patches/100-testing_crosscompile.patch
net/l7-protocols/patches/101-testing-timeit.patch
net/l7-protocols/patches/102-testing-doallspeeds.patch

index 1937fd3baa9a3e3bce6e7a91fb9ae419abe1bc1a..64eeae0e6e24cda5d9a9b1bc13bb6442d00189db 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=l7-protocols
-PKG_VERSION:=2007-11-22
+PKG_VERSION:=2008-04-23
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/l7-filter
-PKG_MD5SUM:=162c988422fec85e1f1c24417a2c600c
+PKG_MD5SUM:=f71420848eb60f7fdca04c2e89c78ee5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -41,7 +41,7 @@ endef
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_l7-protocols-testing),)
   define Build/Compile
-       cd $(PKG_BUILD_DIR)/testing && $(MAKE) $(TARGET_CONFIGURE_OPTS) CXX="$(STAGING_DIR)/usr/bin/g++-uc"
+       cd $(PKG_BUILD_DIR)/testing && $(MAKE) $(TARGET_CONFIGURE_OPTS) CXX="$(STAGING_DIR)/host/bin/g++-uc"
   endef
 else
   define Build/Compile
index 905301b45e34f039ae49444a16b41db9658741f7..70ee2d11e042204dfd28f5f6e8958caaf295715a 100644 (file)
@@ -1,7 +1,5 @@
-Index: l7-protocols-2007-10-10/testing/Makefile
-===================================================================
---- l7-protocols-2007-10-10.orig/testing/Makefile      2007-10-31 14:40:41.000000000 -0500
-+++ l7-protocols-2007-10-10/testing/Makefile   2007-10-31 14:40:41.000000000 -0500
+--- a/testing/Makefile
++++ b/testing/Makefile
 @@ -1,19 +1,19 @@
  all: randchars randprintable test_speed-kernel test_speed-userspace match_kernel
  
index 81d7024eb1e71e6025fe317a85232b292afe3b7c..d272c27a45354a7cbd1415d57ee8d7a75ebfd71e 100644 (file)
@@ -1,7 +1,5 @@
-Index: l7-protocols-2007-10-10/testing/timeit.sh
-===================================================================
---- l7-protocols-2007-10-10.orig/testing/timeit.sh     2007-10-31 15:58:48.000000000 -0500
-+++ l7-protocols-2007-10-10/testing/timeit.sh  2007-10-31 16:02:19.000000000 -0500
+--- a/testing/timeit.sh
++++ b/testing/timeit.sh
 @@ -1,11 +1,8 @@
  #!/bin/bash
  
index 23706d378e911449621d288c31703e25122a074f..59ecaffaf4071a155f327e6c94918a6f6138786f 100644 (file)
@@ -1,7 +1,5 @@
-Index: l7-protocols-2007-10-10/testing/doallspeeds.sh
-===================================================================
---- l7-protocols-2007-10-10.orig/testing/doallspeeds.sh        2007-10-31 16:07:03.000000000 -0500
-+++ l7-protocols-2007-10-10/testing/doallspeeds.sh     2007-10-31 16:07:20.000000000 -0500
+--- a/testing/doallspeeds.sh
++++ b/testing/doallspeeds.sh
 @@ -25,11 +25,11 @@
        printf `basename $f .pat`