Port udp-broadcast-relay to -ng
authorFlorian Fainelli <florian@openwrt.org>
Thu, 10 Aug 2006 21:46:24 +0000 (21:46 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 10 Aug 2006 21:46:24 +0000 (21:46 +0000)
SVN-Revision: 4555

net/udp-broadcast-relay/Makefile [new file with mode: 0644]

diff --git a/net/udp-broadcast-relay/Makefile b/net/udp-broadcast-relay/Makefile
new file mode 100644 (file)
index 0000000..fb917e0
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=udp-broadcast-relay
+PKG_VERSION:=0.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=a32f983b7063d6ac670e6b22be9b9d24
+
+PKG_SOURCE_URL:=http://www.joachim-breitner.de/udp-broadcast-relay/files/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/udp-broadcast-relay
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=listens for packets on a specified UDP broadcast port
+  DESCRIPTION:=This program listens for packets on a specified UDP broadcast port.\\\
+  When a packet is received, it sends that packet to all specified interfaces but\\\
+  the one it came from as though it originated from the original sender.\\\
+  The primary purpose of this is to allow games on machines on separated\\\
+  local networks (Ethernet, WLAN) that use udp broadcasts to find each other to do so.\\\
+  It also works on ppp links, so you can log in from windows boxes (e.g. using pptp)\\\
+  and play LAN-based games together. Currently, you have to care about upcoming or\\\
+  downgoing interfaces yourself.\\\
+  URL:=http://www.joachim-breitner.de/udp-broadcast-relay/
+endef
+
+define Build/Compile   
+       $(TARGET_CC) $(PKG_BUILD_DIR)/main.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+endef
+
+define Package/udp-broadcast-relay/install     
+       mkdir -p $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,udp-broadcast-relay))