Merge pull request #926 from EvanLloyd/win_make_4
authordavidcunado-arm <david.cunado@arm.com>
Mon, 8 May 2017 22:32:52 +0000 (23:32 +0100)
committerGitHub <noreply@github.com>
Mon, 8 May 2017 22:32:52 +0000 (23:32 +0100)
Minor makefile fixes

Makefile
make_helpers/build_macros.mk
make_helpers/unix.mk
make_helpers/windows.mk

index b59d785c01dcf387fd6d5c9f7b52e0d565f43eda..b644b20186970c74adeee06bcae56ac143cabc0b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -629,18 +629,18 @@ ${BUILD_PLAT}/${FIP_NAME}: ${FIP_DEPS} ${FIPTOOL}
 ifneq (${GENERATE_COT},0)
 fwu_certificates: ${FWU_CRT_DEPS} ${CRTTOOL}
        ${Q}${CRTTOOL} ${FWU_CRT_ARGS}
-       @echo
+       @${ECHO_BLANK_LINE}
        @echo "Built $@ successfully"
        @echo "FWU certificates can be found in ${BUILD_PLAT}"
-       @echo
+       @${ECHO_BLANK_LINE}
 endif
 
 ${BUILD_PLAT}/${FWU_FIP_NAME}: ${FWU_FIP_DEPS} ${FIPTOOL}
        ${Q}${FIPTOOL} create ${FWU_FIP_ARGS} $@
        ${Q}${FIPTOOL} info $@
-       @echo
+       @${ECHO_BLANK_LINE}
        @echo "Built $@ successfully"
-       @echo
+       @${ECHO_BLANK_LINE}
 
 fiptool: ${FIPTOOL}
 fip: ${BUILD_PLAT}/${FIP_NAME}
index 2d23ef8b1d84b6a27a8d43f22bce1ba18803b6ea..36f220e08c965c1e7bce2f32678c4f99ff063581 100644 (file)
@@ -284,14 +284,16 @@ define MAKE_BL
         $(eval BL_LINKERFILE := $(BL$(call uppercase,$(1))_LINKERFILE))
         # We use sort only to get a list of unique object directory names.
         # ordering is not relevant but sort removes duplicates.
-        $(eval TEMP_OBJ_DIRS := $(sort $(BUILD_DIR)/ $(dir ${OBJS} ${LINKERFILE})))
+        $(eval TEMP_OBJ_DIRS := $(sort $(dir ${OBJS} ${LINKERFILE})))
         # The $(dir ) function leaves a trailing / on the directory names
         # Rip off the / to match directory names with make rule targets.
         $(eval OBJ_DIRS   := $(patsubst %/,%,$(TEMP_OBJ_DIRS)))
 
 # Create generators for object directory structure
 
-$(eval $(foreach objd,${OBJ_DIRS},$(call MAKE_PREREQ_DIR,${objd},)))
+$(eval $(call MAKE_PREREQ_DIR,${BUILD_DIR},))
+
+$(eval $(foreach objd,${OBJ_DIRS},$(call MAKE_PREREQ_DIR,${objd},${BUILD_DIR})))
 
 .PHONY : bl${1}_dirs
 
@@ -321,9 +323,9 @@ $(DUMP): $(ELF)
 $(BIN): $(ELF)
        @echo "  BIN     $$@"
        $$(Q)$$(OC) -O binary $$< $$@
-       @echo
+       @${ECHO_BLANK_LINE}
        @echo "Built $$@ successfully"
-       @echo
+       @${ECHO_BLANK_LINE}
 
 .PHONY: bl$(1)
 bl$(1): $(BIN) $(DUMP)
index 61b1368b2d4d44dd580d4e823f1aa6e9086c9ec2..17f8a7c279c7a6eed1401fb975ad84e7605e08bc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (c) 2016, ARM Limited and Contributors. All rights reserved.
+# Copyright (c) 2016-2017, ARM Limited and Contributors. All rights reserved.
 #
 # SPDX-License-Identifier: BSD-3-Clause
 #
@@ -43,11 +43,14 @@ ifndef UNIX_MK
 
     # ${1} is the directory to be generated.
     # ${2} is optional, and allows a prerequisite to be specified.
+    # Do nothing if $1 == $2, to ignore self dependencies.
     define MAKE_PREREQ_DIR
+        ifneq (${1},${2})
 
 ${1} : ${2}
        ${Q}mkdir -p  "${1}"
 
+        endif
     endef
 
     define SHELL_REMOVE_DIR
index f6e8d55bdb5e19dc272f4c8ca148b1901ba3a189..69f6a017158c90e04337dcbc0932a23662760d2b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (c) 2016, ARM Limited and Contributors. All rights reserved.
+# Copyright (c) 2016-2017, ARM Limited and Contributors. All rights reserved.
 #
 # SPDX-License-Identifier: BSD-3-Clause
 #
@@ -51,12 +51,15 @@ ifndef WINDOWS_MK
 
     # ${1} is the directory to be generated.
     # ${2} is optional, and allows prerequisites to be specified.
+    # Do nothing if $1 == $2, to ignore self dependencies.
     define MAKE_PREREQ_DIR
+        ifneq (${1},${2})
 
 ${1} : ${2}
        $(eval tmp_dir:=$(subst /,\,${1}))
        -@if not exist "$(tmp_dir)"  mkdir "${tmp_dir}"
 
+        endif
     endef
 
     # ${1} is the directory to be removed.