[backfire] backport r20913
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 16:24:57 +0000 (16:24 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 16:24:57 +0000 (16:24 +0000)
SVN-Revision: 20927

package/kernel/modules/other.mk

index 879ca6e5560697cac4da9eeb0e6f096bda0fb45e..e94b22833f9a59e9859ed77e9ab96ac6ea1d1560 100644 (file)
@@ -261,7 +261,8 @@ $(eval $(call KernelPackage,ssb))
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +!TARGET_x86:kmod-hid
+  DEPENDS:=@USB_SUPPORT +kmod-crc16 +kmod-usb-core +!TARGET_x86:kmod-hid \
+       +(TARGET_x86||TARGET_s3c24xx||TARGET_brcm47xx||TARGET_ar71xx):kmod-rfkill
   KCONFIG:= \
        CONFIG_BLUEZ \
        CONFIG_BLUEZ_L2CAP \