moc: import from oldpackages, add LICENSE info, add myself as pkg maintainer
authorTed Hess <thess@kitschensync.net>
Thu, 31 Jul 2014 17:06:14 +0000 (13:06 -0400)
committerTed Hess <thess@kitschensync.net>
Tue, 5 Aug 2014 20:33:20 +0000 (16:33 -0400)
Signed-off-by: Ted Hess <thess@kitschensync.net>
sound/mocp/Makefile [new file with mode: 0644]

diff --git a/sound/mocp/Makefile b/sound/mocp/Makefile
new file mode 100644 (file)
index 0000000..0bdd231
--- /dev/null
@@ -0,0 +1,64 @@
+#
+# Copyright (C) 2011-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=moc
+PKG_VERSION:=2.5.0-beta2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://ftp.daper.net/pub/soft/moc/unstable/
+PKG_MD5SUM:=da87b90b57934234589b63e347921458
+
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILE:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/moc
+  SECTION:=sound
+  CATEGORY:=Sound
+  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-lib +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg +libltdl +libmagic +faad2 +libdb47
+  TITLE:=Music On Console
+  URL:=http://moc.daper.net/
+endef
+
+define Package/moc/description
+       MOC (music on console) is a console audio player for LINUX/UNIX designed to be powerful and easy to use.
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               $(if $(CONFIG_BUILD_PATENTED),,--without-mp3) \
+               --enable-shared \
+               --disable-static \
+               --disable-debug \
+               --without-speex \
+               --without-samplerate \
+               --without-curl \
+               --without-flac \
+               --without-musepack \
+               --without-rcc \
+               $(if $(CONFIG_PACKAGE_libncursesw),--with-ncursesw --without-ncurses,--with-ncurses --without-ncursesw) \
+       )
+endef
+
+define Package/moc/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mocp $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib/moc/decoder_plugins
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/moc/decoder_plugins/*.so $(1)/usr/lib/moc/decoder_plugins
+endef
+
+$(eval $(call BuildPackage,moc))