freeradius3: switch to pcre2
authorMartin Strobel <arctus@crza.de>
Sun, 29 Oct 2023 15:16:57 +0000 (16:16 +0100)
committerRosen Penev <rosenp@gmail.com>
Mon, 30 Oct 2023 21:01:45 +0000 (14:01 -0700)
use libpcre2 as dependency for freeradius3-common
because PCRE is EOL with no further updates

Compile & run tested on mediatek mt76 ubnt-ui6-lr-v1 with musl

Signed-off-by: Martin Strobel <arctus@crza.de>
net/freeradius3/Makefile

index d908ed81524fe6a00becfed0fa97003716710f01..4a97b841455bcd1858021f85bbf8ccc31876362c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeradius3
 PKG_VERSION:=3.0.26
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=freeradius-server-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://github.com/FreeRADIUS/freeradius-server/releases/download/release_$(subst .,_,$(PKG_VERSION))/
@@ -63,7 +63,7 @@ endef
 define Package/freeradius3-common
   $(call Package/freeradius3/Default)
   TITLE:=common files
-  DEPENDS:=+USE_GLIBC:libpthread +USE_GLIBC:libbsd +FREERADIUS3_OPENSSL:libopenssl +libcap +libpcap +libncurses +libpcre +libreadline +libtalloc +libatomic
+  DEPENDS:=+USE_GLIBC:libpthread +USE_GLIBC:libbsd +FREERADIUS3_OPENSSL:libopenssl +libcap +libpcap +libncurses +libpcre2 +libreadline +libtalloc +libatomic
 endef
 
 define Package/freeradius3-default