smstools3: fix compilation with GCC10 13015/head
authorRosen Penev <rosenp@gmail.com>
Tue, 30 Jun 2020 00:21:17 +0000 (17:21 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 3 Aug 2020 23:45:02 +0000 (16:45 -0700)
GCC10 defaults to -fno-common , which breaks compilation as there are
multiple variables defined outside of the header file.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/smstools3/Makefile

index 3c4850482d0277b3741dd83b5f8ae2e4203a11f6..3a63323a6893523bdb9713b6d4fd8a96ad73fc40 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smstools3
 PKG_VERSION:=3.1.21
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://smstools3.kekekasvi.com/packages/
@@ -43,6 +43,7 @@ TARGET_CFLAGS += $(if $(ICONV_FULL),-D USE_ICONV)
 TARGET_CFLAGS += -D DISABLE_INET_SOCKET
 TARGET_CFLAGS += -W -Wall
 TARGET_CFLAGS += -D_FILE_OFFSET_BITS=64
+TARGET_CFLAGS += -fcommon
 
 MAKE_VARS += LFLAGS="$(TARGET_LDFLAGS) $(if $(ICONV_FULL),-liconv)"