python-s3transfer: Update to 0.6.1, update dependencies
authorJeffery To <jeffery.to@gmail.com>
Thu, 20 Jul 2023 09:52:12 +0000 (17:52 +0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 25 Jul 2023 05:47:29 +0000 (22:47 -0700)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-s3transfer/Makefile

index a6e04f9f1f2f079b478c67b6f230cd6dd14385de..39aa803ef45c37eefd3057bb345701a419e19eb5 100644 (file)
@@ -1,14 +1,15 @@
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=s3transfer
-PKG_VERSION:=0.2.0
-PKG_RELEASE:=2
+PKG_NAME:=python-s3transfer
+PKG_VERSION:=0.6.1
+PKG_RELEASE:=1
 
-PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=f23d5cb7d862b104401d9021fc82e5fa0e0cf57b7660a1331425aab0c691d021
+PYPI_NAME:=s3transfer
+PKG_HASH:=640bb492711f4c0c0905e1f62b6aaeb771881935ad27884852411f8e9cacbca9
 
 PKG_MAINTAINER:=Daniel Danzberger <daniel@dd-wrt.com>
-PKG_LICENSE:=MIT
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE.txt
 
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
@@ -18,10 +19,12 @@ define Package/python3-s3transfer
   SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
-  TITLE:=s3transfer
+  TITLE:=Amazon S3 Transfer Manager
   URL:=https://github.com/boto/s3transfer
   DEPENDS:= \
-       +python3 \
+       +python3-light \
+       +python3-logging \
+       +python3-multiprocessing \
        +python3-botocore
 endef