php8: fix module loading with glibc (refs #16642) 16740/head
authorMichael Heimpold <mhei@heimpold.de>
Sun, 26 Sep 2021 20:05:15 +0000 (22:05 +0200)
committerMichael Heimpold <mhei@heimpold.de>
Sun, 26 Sep 2021 20:05:15 +0000 (22:05 +0200)
Without -ldl linker flag .so extensions are not loaded
when glibc is used. Fix it by providing adjusted LDFLAGS
for this case.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php8/Makefile

index c6f22acc8673453b3128f8b99ed96c37556751ab..5d6f67008db5f9b89f9501bcc68daa586b477f33 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=8.0.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
 PKG_LICENSE:=PHP-3.01
@@ -175,6 +175,10 @@ CONFIGURE_ARGS+= \
        --with-external-pcre \
        --with-zlib="$(STAGING_DIR)/usr"
 
+ifeq ($(CONFIG_LIBC_USE_GLIBC),y)
+TARGET_LDFLAGS += -ldl
+endif
+
 ifneq ($(SDK)$(CONFIG_PACKAGE_php8-mod-bcmath),)
   CONFIGURE_ARGS+= --enable-bcmath=shared
 else