kernel: kmod-phy-smsc: Add new PHY
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 7 Aug 2022 14:00:32 +0000 (16:00 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 13 Aug 2022 22:29:19 +0000 (00:29 +0200)
This adds the SMSC PHY which is needed by the kmod-usb-net-smsc95xx
driver.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 5b016a88f92f25dd7d32438bce3a469f343f4009)

package/kernel/linux/modules/netdevices.mk
package/kernel/linux/modules/usb.mk

index 72b8f5c82ae174faf33e3b0168c4ad4e3f29257f..5ca1a141a81754f50575b9f1334edaa113b7657f 100644 (file)
@@ -292,6 +292,22 @@ endef
 $(eval $(call KernelPackage,phy-realtek))
 
 
+define KernelPackage/phy-smsc
+   SUBMENU:=$(NETWORK_DEVICES_MENU)
+   TITLE:=SMSC PHY driver
+   KCONFIG:=CONFIG_SMSC_PHY
+   DEPENDS:=+kmod-libphy
+   FILES:=$(LINUX_DIR)/drivers/net/phy/smsc.ko
+   AUTOLOAD:=$(call AutoProbe,smsc)
+endef
+
+define KernelPackage/phy-smsc/description
+   Currently supports the LAN83C185, LAN8187 and LAN8700 PHYs
+endef
+
+$(eval $(call KernelPackage,phy-smsc))
+
+
 define KernelPackage/swconfig
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=switch configuration API
index b84e6e61b94336d358658683a12f6d55c44a9cd8..1fc3541f103be0143986143f52ab962e1bc669aa 100644 (file)
@@ -1266,7 +1266,7 @@ $(eval $(call KernelPackage,usb-net-smsc75xx))
 
 define KernelPackage/usb-net-smsc95xx
   TITLE:=SMSC LAN95XX based USB 2.0 10/100 ethernet devices
-  DEPENDS:=+LINUX_5_10:kmod-libphy
+  DEPENDS:=+LINUX_5_10:kmod-libphy +kmod-phy-smsc
   KCONFIG:=CONFIG_USB_NET_SMSC95XX
   FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/smsc95xx.ko
   AUTOLOAD:=$(call AutoProbe,smsc95xx)