packages/seeks: use new service functions
authorNicolas Thill <nico@openwrt.org>
Mon, 14 Nov 2011 02:38:40 +0000 (02:38 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 14 Nov 2011 02:38:40 +0000 (02:38 +0000)
SVN-Revision: 29093

net/seeks/Makefile
net/seeks/files/seeks.init

index 4f72e9d44fdcdabde917101057f3cd574282ec73..becf6da829157368178e9f4df6f47d6e6320a7f8 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=seeks
 PKG_VERSION:=0.3.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
index c636d6b293558bfd2fdf9013fe644cc018885250..eb4c5e40d94092b5d4d96d7dbff8e44e1f4a30a9 100644 (file)
@@ -1,21 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
-START=99
+# Copyright (C) 2011 OpenWrt.org
 
-DAEMON=/usr/bin/seeks
+START=99
 
 start() {
-       echo 'seeks is starting...'
-       start-stop-daemon -S -q -x "$DAEMON" -- --daemon
+       service_start /usr/bin/seeks --daemon
 }
 
 stop() {
-       echo 'seeks is stopping...'
-       start-stop-daemon -K -q -x "$DAEMON"
-}
-
-restart() {
-       stop
-       sleep 2
-       start
+       service_stop /usr/bin/seeks
 }