[packages] portmap fixes:
authorNicolas Thill <nico@openwrt.org>
Fri, 2 May 2008 01:20:40 +0000 (01:20 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 2 May 2008 01:20:40 +0000 (01:20 +0000)
 - disable pie (closes: #3095)
 - use start-stop-daemon
 - bump release number

SVN-Revision: 11001

net/portmap/Makefile
net/portmap/files/portmap.init
net/portmap/patches/101-no_pie.patch [new file with mode: 0644]

index 9c8ddf052351c48e6b89065f8512125f8ce751c4..720f8a555be56a19ed8240040c2e9550bd5b6e4b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=portmap
 PKG_VERSION:=6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://neil.brown.name/portmap/
index 3bbfb573f8c2239b48fd74d7f66fb52dd8613be5..97ee0d706ae4a00e16f01f500f94b560c7976b7b 100644 (file)
@@ -1,16 +1,16 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 
 START=40
-BIN=portmap
-DEFAULT=/etc/default/$BIN
+NAME=portmap
+PROG=/usr/sbin/$NAME
+DEFAULT=/etc/default/$NAME
 
 start() {
        [ -f $DEFAULT ] && . $DEFAULT
-       $BIN $OPTIONS
+       start-stop-daemon -q -S -x $PROG -- $OPTIONS
 }
 
 stop() {
-       killall $BIN
+       start-stop-daemon -q -K -x $PROG -- $OPTIONS
 }
-
diff --git a/net/portmap/patches/101-no_pie.patch b/net/portmap/patches/101-no_pie.patch
new file mode 100644 (file)
index 0000000..6cbdece
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ur portmap_6.0.org/Makefile portmap_6.0/Makefile
+--- portmap_6.0.org/Makefile   2008-04-19 22:44:35.000000000 +0200
++++ portmap_6.0/Makefile       2008-04-19 00:02:01.000000000 +0200
+@@ -127,7 +127,7 @@
+ CPPFLAGS += $(HOSTS_ACCESS)
+ portmap: CFLAGS   += -fpie
+ portmap: LDLIBS   += $(WRAP_LIB)
+-portmap: LDFLAGS  += -pie
++#portmap: LDFLAGS  += -pie
+ portmap: portmap.o pmap_check.o from_local.o
+ from_local: CPPFLAGS += -DTEST