OpenWrt v21.02: set branch defaults
authorAlexander Couzens <lynxis@fe80.eu>
Tue, 16 Feb 2021 01:16:25 +0000 (02:16 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Tue, 16 Feb 2021 01:21:33 +0000 (02:21 +0100)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
feeds.conf.default
include/version.mk
package/base-files/image-config.in

index 03bfacb620fd9f9bd489b1d5009d09c3f75fb462..c30a8fbc239f569eeec2110bf8a7441b9cffa8e4 100644 (file)
@@ -1,10 +1,6 @@
-src-git packages https://git.openwrt.org/feed/packages.git
-src-git luci https://git.openwrt.org/project/luci.git
-src-git routing https://git.openwrt.org/feed/routing.git
-src-git telephony https://git.openwrt.org/feed/telephony.git
-src-git freifunk https://github.com/freifunk/openwrt-packages.git
-#src-git video https://github.com/openwrt/video.git
-#src-git targets https://github.com/openwrt/targets.git
-#src-git management https://github.com/openwrt-management/packages.git
-#src-git oldpackages http://git.openwrt.org/packages.git
+src-git packages https://git.openwrt.org/feed/packages.git;openwrt-21.02
+src-git luci https://git.openwrt.org/project/luci.git;openwrt-21.02
+src-git routing https://git.openwrt.org/feed/routing.git;openwrt-21.02
+src-git telephony https://git.openwrt.org/feed/telephony.git;openwrt-21.02
+src-git freifunk https://github.com/freifunk/openwrt-packages.git;openwrt-21.02
 #src-link custom /usr/src/openwrt/custom-feed
index f39e35cd099a7df15029cd25001dfe1e169b309b..a4b47c8a57782e7aacab12c735c1210aa586683d 100644 (file)
@@ -23,13 +23,13 @@ PKG_CONFIG_DEPENDS += \
 sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
 
 VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),21.02-SNAPSHOT)
 
 VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_CODE))
 VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
 
 VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),https://downloads.openwrt.org/snapshots)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),https://downloads.openwrt.org/releases/21.02-SNAPSHOT)
 
 VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
index b5cd90f6152df003b6f2c95c5479a84a7138f59e..1f06332b00444989e33bb38b5953ab0e76983bd7 100644 (file)
@@ -183,7 +183,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "https://downloads.openwrt.org/snapshots"
+               default "https://downloads.openwrt.org/releases/21.02-SNAPSHOT"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders: