[PATCH] fix uclib bug in jamvm
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 22 May 2009 13:09:45 +0000 (13:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 22 May 2009 13:09:45 +0000 (13:09 +0000)
I just realized that tls has some problems with ulibc. This patch disables
it and uses more opewrt-style install directories for libraries.
Signed-off-by: Roberto Riggio <roberto.riggio@create-net.org>
SVN-Revision: 15988

lang/jamvm/Makefile
libs/classpath/Makefile

index bf7ae808103a7e86b6302c5f2126b01239142a3b..95b09d160a60f745ef24d35ab71195c66119d9f9 100644 (file)
@@ -36,6 +36,8 @@ define Package/jamvm/description
 endef
 
 CONFIGURE_ARGS+= \
+       --with-classpath-install-dir=/usr \
+       --disable-tls \
        --enable-ffi \
        --disable-int-threading \
 
index 3941f0aca1765f75ede11fba656e21dae9dc74dd..e7561b0debb23e4ccc9de86e88c03143ea0b12ea 100644 (file)
@@ -45,10 +45,10 @@ define Build/Compile
 endef
 
 define Package/classpath/install
-       $(INSTALL_DIR) $(1)/usr/local/classpath/share/classpath/
-       $(INSTALL_DIR) $(1)/usr/local/classpath/lib/classpath/
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/classpath/glibj.zip $(1)/usr/local/classpath/share/classpath/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/classpath/* $(1)/usr/local/classpath/lib/classpath/
+       $(INSTALL_DIR) $(1)/usr/share/classpath
+       $(INSTALL_DIR) $(1)/usr/lib/classpath
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/classpath/glibj.zip $(1)/usr/share/classpath/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/classpath/* $(1)/usr/lib/classpath/
 endef
 
 $(eval $(call BuildPackage,classpath))