1. Updated to git HEAD b4ed2f55bf4f68ab83b16884dfcd3d6421ac25c0.
authorMazilo <openwrt.forum.mazilo@recursor.net>
Thu, 6 Jun 2013 01:12:00 +0000 (21:12 -0400)
committerMazilo <openwrt.forum.mazilo@recursor.net>
Thu, 6 Jun 2013 01:12:00 +0000 (21:12 -0400)
2. Added options to enable/disable compile with ALSA and PostgreSQL (default disabled). Any modules that depends on either alsa-lib or libpq, i.e. mod-alsa, mod_cdr-pg-csv, etc., will no longer show on menu unless "Compile with ALSA support" and/or "Compile with PostgreSQL" option is enabled.
3. Fixed typo in CONFIGURE_ARGS (--without-iogg -> --without-ogg).
4. Removed BuildLib. Module packages that depend on BuildLib scripts now directly calls their dependencies.
5. Fixed some installation scripts in BuildPlugin.
6. Removed libgcrypt dependency from mod_dingaling.

Signed-off-by: Mazilo <mazilo@Mi.HomeLinux.net>
freeswitch/Makefile
freeswitch/patches/001-build-modules_conf_in.patch
freeswitch/patches/002-configure_in.patch
freeswitch/patches/003-Makefile.am.patch
freeswitch/patches/107-libs-libzrtp-include-zrtp_config_h.patch
freeswitch/patches/201-src-mod-applications-mod_mp4-mp4_helper_hpp.patch [deleted file]

index ab66c4571fd128ed4dbbf003bb1fc43f36e43284..9c312cfafd2397badadbd01a776c0ab3bddcbaf0 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeswitch
 PKG_DISTNAME:=$(PKG_NAME)_git
-PKG_VERSION:=1.3.17
+PKG_VERSION:=1.5.2b
 
 
 #
@@ -18,7 +18,7 @@ PKG_VERSION:=1.3.17
 #
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
-FS_DEFAULT_HEAD:=6af84a870c21836e20077f27a85d94fd382a02be
+FS_DEFAULT_HEAD:=b4ed2f55bf4f68ab83b16884dfcd3d6421ac25c0
 FS_LATEST_HEAD:=$(if $(DUMP),$(FS_DEFAULT_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD | cut -f1))
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_SOFIA_WITH_PULL_CURRENT),$(FS_LATEST_HEAD),$(FS_DEFAULT_HEAD))
 PKG_SOURCE_VERSION_SHORT:=$(shell echo $(PKG_SOURCE_VERSION)|cut -b -7)
@@ -28,7 +28,7 @@ PKG_SOURCE:=$(PKG_SOURCE_SUBDIR)-$(PKG_SOURCE_VERSION_SHORT).tar.bz2
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 
-PKG_FIXUP:=autoreconf
+PKG_FIXUP:=libtool autoreconf
 PKG_BUILD_PARALLEL:=1
 
 
@@ -163,11 +163,14 @@ FS_MOD_AVAILABLE:= \
 
 
 PKG_CONFIG_DEPENDS:= \
+       CONFIG_FS_SOFIA_WITH_ALSA \
        CONFIG_FS_SOFIA_WITH_BUILTIN_ZRTP \
+       CONFIG_FS_SOFIA_WITH_FIXED_POINT \
        CONFIG_FS_SOFIA_WITH_IPV6 \
        CONFIG_FS_SOFIA_WITH_MYSQL \
        CONFIG_FS_SOFIA_WITH_ODBC \
        CONFIG_FS_SOFIA_WITH_OPT \
+       CONFIG_FS_SOFIA_WITH_POSTGRESQL \
        CONFIG_FS_SOFIA_WITH_PULL_CURRENT \
        CONFIG_FS_SOFIA_WITH_SCTP \
        $(patsubst %,CONFIG_PACKAGE_$(PKG_NAME)-mod-%,$(FS_MOD_AVAILABLE)) \
@@ -192,7 +195,7 @@ endef
 define Package/$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   TITLE:=FreeSWITCH open source telephony platform ($(PKG_SOURCE_VERSION_SHORT))
-  DEPENDS:=+libcurl +libiconv-full +libjpeg +libncurses +libpq +libpthread +librt +libstdcpp
+  DEPENDS:=+libcurl +libiconv-full +libjpeg +libncurses +libpthread +librt +libstdcpp
   MENU:=1
 endef
 
@@ -217,6 +220,13 @@ define Package/$(PKG_NAME)/config
        compiled and may require some intervension to create new patches. If you take this route
        and come up with some patches, please contemplate to contribute or send in your patches.
 
+    config FS_SOFIA_WITH_ALSA
+    depends on PACKAGE_$(PKG_NAME)
+    bool "Compile with ALSA support"
+    default n
+    help
+        Compile $(PKG_NAME) with ALSA Support.
+
     config FS_SOFIA_WITH_IPV6
     depends on PACKAGE_$(PKG_NAME)
     bool "Compile with IPV6 support"
@@ -249,6 +259,14 @@ define Package/$(PKG_NAME)-mod-sofia/config
     help
         Compile $(PKG_NAME) with MySQL.
 
+    config FS_SOFIA_WITH_POSTGRESQL
+    depends on PACKAGE_$(PKG_NAME)-mod-sofia
+    bool "Compile with PostgreSQL"
+    default n
+    select PACKAGE_libpq
+    help
+        Compile $(PKG_NAME) with PostgreSQL.
+
     config FS_SOFIA_WITH_ODBC
     depends on PACKAGE_$(PKG_NAME)-mod-sofia
     depends on PACKAGE_sqliteodbc
@@ -268,6 +286,16 @@ define Package/$(PKG_NAME)-mod-sofia/config
 endef
 
 
+define Package/$(PKG_NAME)-mod-spandsp/config
+    config FS_SOFIA_WITH_FIXED_POINT
+    depends on FS_SOFIA_WITH_MYSQL && PACKAGE_$(PKG_NAME)-mod-spandsp
+    bool "Enable fixed point support (may degrade performance)"
+    default n
+    help
+       Compile spandsp package with a fixed point support. ONLY enabled this option when necessary, i.e. CPU doesn't support floating computation.
+endef
+
+
 define Package/$(PKG_NAME)-example-config
 $(call Package/$(PKG_NAME)/Default)
   TITLE:=FreeSWITCH example config (commented)
@@ -534,7 +562,7 @@ endif
 
 FS_TARGET_CFLAGS:= $(TARGET_CFLAGS) -DLUA_USE_LINUX $(FPIC) -std=gnu99 -Wno-format
 FS_TARGET_CXXFLAGS:= $(TARGET_CXXFLAGS) -DLUA_USE_LINUX $(FPIC) -Wno-format
-FS_TARGET_CPPFLAGS:= -I. -I./lua $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-erlang-event),-I$(STAGING_DIR_HOST)/lib/erlang/lib/erl_interface-3.6/include) $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-json-cdr),-Wno-error) $(TARGET_CPPFLAGS)
+FS_TARGET_CPPFLAGS:= -I. -I./lua $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-erlang-event),-I$(STAGING_DIR_HOST)/lib/erlang/lib/erl_interface-3.7.7/include) $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-json-cdr),-Wno-error) $(TARGET_CPPFLAGS)
 
 
 CONFIGURE_ARGS+= \
@@ -550,9 +578,12 @@ CONFIGURE_ARGS+= \
        $(if $(CONFIG_FS_SOFIA_WITH_MYSQL),--with-mysql,--without-mysql) \
        $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_IPV6,ipv6) \
        $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_OPT,optimization) \
-       $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-celt),--with-ogg="$(STAGING_DIR)/usr",--without-iogg) \
+       $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-erlang-event),--with-erlang,--without-erlang) \
+       $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-celt),--with-ogg="$(STAGING_DIR)/usr",--without-ogg) \
        $(if ($(CONFIG_PACKAGE_$(PKG_NAME)-mod-curl)|$(CONFIG_PACKAGE_$(PKG_NAME)-mod-xml-cdr)|$(CONFIG_PACKAGE_$(PKG_NAME)-mod-xml-curl)),--with-libcurl="$(STAGING_DIR)/usr",--without-libcurl) \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-java),--with-java="$(STAGING_DIR)/usr",--without-java) \
+       $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_POSTGRESQL,core-pgsql-support) \
+       $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp && CONFIG_FS_SOFIA_WITH_FIXED_POINT,fixed-point) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-spandsp,builtin-tiff) \
        $(call autoconf_bool,CONFIG_PACKAGE_$(PKG_NAME)-mod-timerfd,timerfd-wrapper) \
        $(call autoconf_bool,CONFIG_FS_SOFIA_WITH_BUILTIN_ZRTP,zrtp) \
@@ -719,7 +750,7 @@ define Package/$(PKG_NAME)-config-minimal/install
        # Copying dialplan directory jingle_profiles sip_profiles $(PKG_NAME).xml
        # fur_elise.ttml mime.types tetris.ttml tones.conf vars.xml
        #
-       $(foreach f,dialplan directory jingle_profiles sip_profiles $(PKG_NAME).xml fur_elise.ttml mime.types tetris.ttml tones.conf vars.xml,$(if $(PKG_BUILD_DIR)/conf/vanilla/$(f),$(CP) $(PKG_BUILD_DIR)/conf/vanilla/$(f) $(1)/etc/$(PKG_NAME);))
+       $(foreach f,dialplan directory jingle_profiles sip_profiles $(PKG_NAME).xml fur_elise.ttml mime.types tetris.ttml vars.xml,$(if $(PKG_BUILD_DIR)/conf/vanilla/$(f),$(CP) $(PKG_BUILD_DIR)/conf/vanilla/$(f) $(1)/etc/$(PKG_NAME);))
 
        #
        # Copying acl ivr modules post_load_modules switch timezones
@@ -823,33 +854,6 @@ define Package/$(PKG_NAME)-tools/install
 endef
 
 
-#
-# 1. Name
-# 2. Title
-# 3. Package configuration files
-# 4. Inter module depends
-# 5. Extra depends
-#
-define BuildLib
-  define Package/$(PKG_NAME)-$(1)
-    $$(call Package/$(PKG_NAME)/Default)
-    TITLE:= FS $(2) library and pkgconfig files
-    DEPENDS:= $(PKG_NAME) $(foreach l,$(4),+$(PKG_NAME)-$(l)) $(5)
-  endef
-
-  define Package/$(PKG_NAME)-$(1)/install
-       [ -d "$$(1)/usr/lib/pkgconfig" ] || $(INSTALL_DIR) $$(1)/usr/lib/pkgconfig
-
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/$(patsubst lib%,%,$(3)).pc $$(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/$(1)* $$(1)/usr/lib/
-       $(if $$(1)/usr/lib/$(1).la,sed -i -e "s#\(^.*\)=' \(.*\)-lm\(.*\)#\1=' -L/usr/lib -L/usr/lib/libiconv-full/lib -L/usr/lib/libintl-full/lib -lm\3#g" $$(1)/usr/lib/$(1).la)
-  endef
-
-  $$(eval $$(call BuildPackage,$(PKG_NAME)-$(1)))
-endef
-
-
-#
 # 1. Name
 # 2. Title
 # 3. Selection on module configuration file
@@ -876,7 +880,7 @@ define BuildPlugin
        #
        # mod_$(subst -,_,$(1)): $(5)
        #
-       $(foreach f,$(5),[ -d $(dir $$(1)/usr/${f}) ] || $(INSTALL_DIR) $(dir $$(1)/usr/${f});$(CP) $(PKG_INSTALL_DIR)/usr/${f} $$(1)/usr;)
+       $(foreach f,$(5),[ -d $(dir $$(1)/usr/${f}) ] || $(INSTALL_DIR) $(dir $$(1)/usr/${f});$(CP) $$$$(wildcard $(PKG_INSTALL_DIR)/usr/${f}*) $(dir $$(1)/usr/${f});)
 
        #
        # mod_$(subst -,_,$(1)): Clean installed library control files from referencig to OpenWRT PATH.
@@ -948,17 +952,11 @@ $(eval $(call BuildPackage,$(PKG_NAME)-config-upstream-defaults))
 $(eval $(call BuildPackage,$(PKG_NAME)-config-minimal))
 
 
-#
-# $(eval $(call BuildLib,Name,Title,Package Configuration Files,Inter Depends,Extra Depends))
-#
-$(eval $(call BuildLib,libopenzap,OpenZAP,openzap,,))
-
-
 #
 # $(eval $(call BuildPlugin,Name,Title,Selection on module Conf File,Files,Inter Depends,Extra Depends))
 #
 $(eval $(call BuildPlugin,abstraction,An Abstraction To API Call,vanilla,,,,))
-$(eval $(call BuildPlugin,alsa,Alsa Endpoint,vanilla,,,,+alsa-lib))
+$(eval $(call BuildPlugin,alsa,Alsa Endpoint,vanilla,,,,+alsa-lib @FS_SOFIA_WITH_ALSA))
 $(eval $(call BuildPlugin,amr,Adaptive Multi-Rate On Bandwidth Codec,vanilla,,,,))
 $(eval $(call BuildPlugin,amrwb,Wide Band AMR,vanilla,,,,))
 $(eval $(call BuildPlugin,avmd,Advanced Voice Mail Detection,vanilla,,,,))
@@ -966,7 +964,7 @@ $(eval $(call BuildPlugin,blacklist,Blacklist,vanilla,,,,))
 $(eval $(call BuildPlugin,bv,BroadVoice 16/32-bit Audio Codec,vanilla,,,,))
 $(eval $(call BuildPlugin,callcenter,Call Center,vanilla,,,,))
 $(eval $(call BuildPlugin,cdr-csv,CSV-CDR Handler,mod,,,,)) # ~/conf
-$(eval $(call BuildPlugin,cdr-pg-csv,Postgress CDR Handler,vanilla,,,,+coreutils +libpq))
+$(eval $(call BuildPlugin,cdr-pg-csv,Postgress CDR Handler,vanilla,,,,+coreutils @FS_SOFIA_WITH_POSTGRESQL))
 $(eval $(call BuildPlugin,cdr-sqlite,SQLite3 CDR Handler,vanilla,,,,+libsqlite3))
 $(eval $(call BuildPlugin,celt,CELT Ultra-Low Delay Codec,vanilla,,,,+libogg))
 $(eval $(call BuildPlugin,cepstral,Cepstral Interface,vanilla,,,,@BROKEN)) # needs <swift.h>
@@ -982,9 +980,9 @@ $(eval $(call BuildPlugin,db,Database Backend,vanilla,,,,))
 $(eval $(call BuildPlugin,dialplan-asterisk,Asterisk Dialplan Parser,vanilla,,,,))
 $(eval $(call BuildPlugin,dialplan-directory,Dialplan Directory,vanilla,,,,))
 $(eval $(call BuildPlugin,dialplan-xml,Dialplan-XML Interface,vanilla,,,,))
-$(eval $(call BuildPlugin,dingaling,Jabber Interface,vanilla,,,,+libgcrypt +libopenssl))
+$(eval $(call BuildPlugin,dingaling,Jabber Interface,vanilla,,,,+libopenssl))
 $(eval $(call BuildPlugin,directory,Search By Name Directory IVR,vanilla,,,,))
-$(eval $(call BuildPlugin,distributor,Simple Robin-Round Load to Gateway,vanilla,,,,))
+$(eval $(call BuildPlugin,distributor,Simple Robin-Round Load,vanilla,,,,))
 $(eval $(call BuildPlugin,dptools,Dialplan Tools,vanilla,,,,))
 $(eval $(call BuildPlugin,easyroute,Simple DID Routing,vanilla,,,,))
 $(eval $(call BuildPlugin,enum,ENUM Routing,,,,,))
@@ -1001,7 +999,7 @@ $(eval $(call BuildPlugin,fsk,Bell-202 1200-Baud FSK Decoder,vanilla,,,,))
 $(eval $(call BuildPlugin,fsv,Video Player / Recorder,vanilla,,,,))
 $(eval $(call BuildPlugin,g723-1,G.723.1 Codec,vanilla,,,,))
 $(eval $(call BuildPlugin,g729,G.729 Codec,vanilla,,,,))
-$(eval $(call BuildPlugin,gsmopen,GSM Modem compatible Endpoint,mod,,,,+alsa-lib @BROKEN)) # needs gsmlib
+$(eval $(call BuildPlugin,gsmopen,GSM Modem compatible Endpoint,mod,,,alsa,+alsa-lib @FS_SOFIA_WITH_ALSA @BROKEN)) # needs gsmlib
 $(eval $(call BuildPlugin,h26x,H26X Linear Codec,vanilla,,,,))
 $(eval $(call BuildPlugin,h323,H323 Endpoint,mod,,,,@BROKEN)) # Req. H323Plus v1.24.x or newer
 $(eval $(call BuildPlugin,hash,API For Manipulating A Hash Table,vanilla,,,,))
@@ -1023,12 +1021,12 @@ $(eval $(call BuildPlugin,mp4v,MP4 CoDec Support For Video,vanilla,,,,))
 $(eval $(call BuildPlugin,native-file,WAV Format Sound Player,vanilla,,,,))
 $(eval $(call BuildPlugin,nibblebill,Credit / Debit Billing,vanilla,,,,))
 $(eval $(call BuildPlugin,oreka,Media Recording with Oreka,vanilla,,,,))
-$(eval $(call BuildPlugin,openzap,Zaptel (Superseded by FreeTDM),libs,ozmod,,,+$(PKG_NAME)-libopenzap +libpcap))
+$(eval $(call BuildPlugin,openzap,Zaptel (Superseded by FreeTDM),libs,ozmod,lib/libopenzap lib/pkgconfig/openzap,,+libpcap))
 $(eval $(call BuildPlugin,opus,Opus CoDec,vanilla,,,,))
-$(eval $(call BuildPlugin,portaudio,Portaudio To Sound Card Interface,vanilla,,,,+alsa-lib))
-$(eval $(call BuildPlugin,portaudio-stream,Portaudio Streaming Interface,vanilla,,,,+alsa-lib))
+$(eval $(call BuildPlugin,portaudio,Portaudio To Sound Card Interface,vanilla,,,alsa,+alsa-lib @FS_SOFIA_WITH_ALSA))
+$(eval $(call BuildPlugin,portaudio-stream,Portaudio Streaming Interface,vanilla,,,alsa,+alsa-lib @FS_SOFIA_WITH_ALSA))
 $(eval $(call BuildPlugin,posix-timer,POSIX Compliant Soft Timer,vanilla,,,,))
-$(eval $(call BuildPlugin,radius-cdr,Radius-CDR interface,vanilla,,,,+freeradius2 @BROKEN)) # fails in freeradius-client
+$(eval $(call BuildPlugin,radius-cdr,Radius-CDR interface,vanilla,,,,@BROKEN)) # fails in freeradius-client
 $(eval $(call BuildPlugin,redis,Redis Limited Backend,vanilla,,,,))
 $(eval $(call BuildPlugin,rss,RRS Feeds via TTS,vanilla,,,,))
 $(eval $(call BuildPlugin,rtmp,RTMP Protocol Handler,vanilla,,,,))
index 736d9a47b24e595588b7fdb18f27f1e86bbfa8fa..3ed7b83122a30f13c5177fded6e43fc26e559ec2 100644 (file)
@@ -26,7 +26,7 @@
  #applications/mod_soundtouch
  applications/mod_spandsp
  #applications/mod_spy
-@@ -61,17 +66,20 @@ codecs/mod_h26x
+@@ -63,17 +68,20 @@ codecs/mod_h26x
  codecs/mod_vp8
  #codecs/mod_ilbc
  #codecs/mod_isac
@@ -47,7 +47,7 @@
  #endpoints/mod_h323
  #endpoints/mod_html5
  #endpoints/mod_khomp
-@@ -88,6 +96,7 @@ event_handlers/mod_cdr_csv
+@@ -90,6 +98,7 @@ event_handlers/mod_cdr_csv
  event_handlers/mod_cdr_sqlite
  #event_handlers/mod_erlang_event
  #event_handlers/mod_event_multicast
@@ -55,7 +55,7 @@
  event_handlers/mod_event_socket
  #event_handlers/mod_event_zmq
  #event_handlers/mod_radius_cdr
-@@ -113,6 +122,7 @@ loggers/mod_syslog
+@@ -115,6 +124,7 @@ loggers/mod_syslog
  #say/mod_say_de
  say/mod_say_en
  #say/mod_say_es
index 326112c3b2a09372d60b805faeac9b5423ce2400..3dd57a3a59e04dd98e5b7baa4dbf7f47fa7dda8e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.in
 +++ b/configure.in
-@@ -152,7 +152,7 @@ if test "${enable_optimizer}" = "yes" ;
+@@ -157,7 +157,7 @@ if test "${enable_optimizer}" = "yes" ;
          AX_CC_MAXOPT
  fi
  
@@ -9,7 +9,7 @@
  
  # set defaults for use on all platforms
  SWITCH_AM_CFLAGS="-I${switch_srcdir}/src/include -I${switch_builddir}/src/include -I${switch_srcdir}/libs/libteletone/src -I${switch_srcdir}/libs/stfu"
-@@ -581,7 +581,7 @@ AC_CHECK_LIB(pthread, pthread_setschedpa
+@@ -592,7 +592,7 @@ AC_CHECK_LIB(pthread, pthread_setschedpa
  
  AC_CHECK_FUNC(socket, , AC_CHECK_LIB(socket, socket))
  
index af128f9696585fdebcf5d1cfb0c6369871846b4e..9bab90d7aecf08669d9fbe6e85cffe385079c87a 100644 (file)
@@ -16,7 +16,7 @@
  endif
  
  library_includedir      = $(includedir)
-@@ -422,7 +425,7 @@ $(switch_builddir)/quiet_libtool: $(swit
+@@ -426,7 +429,7 @@ $(switch_builddir)/quiet_libtool: $(swit
        @cat libtool | sed -e 's|$$show "$$command"|if test -z "$$suppress_output" ; then $$show "Compiling $$srcfile ..." ; fi|' > $(switch_builddir)/quiet_libtool
  
  build/print_git_revision: build/print_git_revision.c
@@ -25,7 +25,7 @@
  
  src/include/switch_version.h: src/include/switch_version.h.in Makefile build/print_git_revision $(libfreeswitch_la_SOURCES) $(library_include_HEADERS)
        @cat $< > $@; \
-@@ -648,7 +651,9 @@ sndfile-reconf:
+@@ -664,7 +667,9 @@ sndfile-reconf:
  
  tiff-reconf:
        cd libs/tiff-4.0.2 && autoreconf -fi
@@ -36,7 +36,7 @@
        cd libs/tiff-4.0.2 && make
  
  python-reconf:
-@@ -673,9 +678,6 @@ iks-reconf:
+@@ -689,9 +694,6 @@ iks-reconf:
        $(MAKE) mod_dingaling-clean
  
  spandsp-reconf: tiff-reconf
index e460bc49c0b48bb83f51c9d2c1df1b2b0a7a7472..04638852c6f95f73cd35ac0022b6bef17fb2fca4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/libs/libzrtp/include/zrtp_config.h
 +++ b/libs/libzrtp/include/zrtp_config.h
-@@ -66,8 +66,16 @@
+@@ -68,8 +68,16 @@
   * If the byte order is not specified manually in zrtp_config_user.h - try to detect it automatically
   */
  #if !defined(ZRTP_BYTE_ORDER)
diff --git a/freeswitch/patches/201-src-mod-applications-mod_mp4-mp4_helper_hpp.patch b/freeswitch/patches/201-src-mod-applications-mod_mp4-mp4_helper_hpp.patch
deleted file mode 100644 (file)
index ac81dd0..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/src/mod/applications/mod_mp4/mp4_helper.hpp
-+++ b/src/mod/applications/mod_mp4/mp4_helper.hpp
-@@ -22,8 +22,9 @@ the Initial Developer. All Rights Reserv
- #ifndef MP4_HELPER_HPP_
- #define MP4_HELPER_HPP_
-+#include <string.h>
-+#include <sys/types.h>
- #include <mp4.h>
--#include <string>
- #include <exception>
- #include <string>