alpine: update to 2.22 11435/head
authorRosen Penev <rosenp@gmail.com>
Wed, 26 Feb 2020 04:45:22 +0000 (20:45 -0800)
committerRosen Penev <rosenp@gmail.com>
Fri, 28 Feb 2020 23:09:25 +0000 (15:09 -0800)
Switch to standard tarballs. Remove autoreconf as a result.

Simplify NLS and IPv6 handling. Removed options are default.

Remove upstreamed patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
mail/alpine/Makefile
mail/alpine/patches/010-openssl-deprecated.patch [deleted file]

index 26049dfd3397367adee70ddf6ec14607caafe9e7..d0979300bca2b3f19c341369acbbfde0f24b5b19 100644 (file)
@@ -8,21 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alpine
-PKG_VERSION:=2.21.9999
-PKG_RELEASE:=2
+PKG_VERSION:=2.22
+PKG_RELEASE:=1
 
-PKG_SOURCE_PROTO:=git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://repo.or.cz/alpine.git
-PKG_SOURCE_VERSION:=d3e6f3932f2af9deca8eed09e30a55e9bd524362
-PKG_MIRROR_HASH:=72f9e8c4c3ecbd5f73f527af98ad23f716fcede3af0ab0400c6e0bc9b1288e30
+PKG_SOURCE_URL:=http://alpine.x10host.com/alpine/release/src
+PKG_HASH:=849567c1b6f71fde3aaa1c97cf0577b12a525d9e22c0ea47797c4bf1cd2bbfdb
 
 PKG_MAINTAINER:=Antti Seppälä <a.seppala@gmail.com>
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
-PKG_FIXUP:=autoreconf
-
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
@@ -80,6 +76,7 @@ CONFIGURE_ARGS += \
        --disable-debug \
        --disable-mouse \
        --with-c-client-target=slx \
+       $(if $(CONFIG_IPV6),--with,--without)-ipv6
 
 CONFIGURE_VARS += \
        top_builddir=$(PKG_BUILD_DIR)
@@ -88,23 +85,11 @@ ifeq ($(BUILD_VARIANT),ssl)
        CONFIGURE_ARGS += \
                --with-ssl-include-dir=$(STAGING_DIR)/usr/include/openssl/. \
                --with-ssl-lib-dir=$(STAGING_DIR)/usr/lib
-endif
-
-ifeq ($(BUILD_VARIANT),nossl)
+else
        CONFIGURE_ARGS += \
                --without-ssl
 endif
 
-ifeq ($(CONFIG_BUILD_NLS),y)
-  DISABLE_NLS:=
-endif
-
-ifeq ($(CONFIG_IPV6),y)
-  DISABLE_IPV6:=
-else
-  DISABLE_IPV6:=--without-ipv6
-endif
-
 define Build/Compile
        ( cd $(PKG_BUILD_DIR)/pith ; \
                $(HOSTCC) help_h_gen.c -c -o help_h_gen.o ; \
@@ -117,7 +102,7 @@ endef
 
 define Package/alpine/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/$(PKG_NAME)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/alpine $(1)/usr/bin/
 endef
 
 Package/alpine-nossl/install = $(Package/alpine/install)
diff --git a/mail/alpine/patches/010-openssl-deprecated.patch b/mail/alpine/patches/010-openssl-deprecated.patch
deleted file mode 100644 (file)
index 5426b81..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/imap/src/osdep/unix/ssl_unix.c b/imap/src/osdep/unix/ssl_unix.c
-index 4c4d6ef..f2df2f2 100644
---- a/imap/src/osdep/unix/ssl_unix.c
-+++ b/imap/src/osdep/unix/ssl_unix.c
-@@ -33,9 +33,9 @@
- #include <bio.h>
- #include <crypto.h>
- #include <rand.h>
--#ifdef OPENSSL_1_1_0
- #include <rsa.h>
- #include <bn.h>
-+#ifdef OPENSSL_1_1_0
- #ifdef TLSv1_1_client_method
- #undef TLSv1_1_client_method
- #endif /* TLSv1_1_client_method */
-@@ -862,22 +862,16 @@ static RSA *ssl_genkey (SSL_CTX_TYPE *con,int export,int keylength)
-   static RSA *key = NIL;
-   if (!key) {                 /* if don't have a key already */
-                               /* generate key */
--#ifdef OPENSSL_1_1_0
-     BIGNUM *e = BN_new();
-     if (!RSA_generate_key_ex (key, export ? keylength : 1024, e,NIL)) {
--#else
--    if (!(key = RSA_generate_key (export ? keylength : 1024,RSA_F4,NIL,NIL))) {
--#endif /* OPENSSL_1_1_0 */
-       syslog (LOG_ALERT,"Unable to generate temp key, host=%.80s",
-             tcp_clienthost ());
-       while ((i = ERR_get_error ()) != 0L)
-       syslog (LOG_ALERT,"SSL error status: %s",ERR_error_string (i,NIL));
-       exit (1);
-     }
--#ifdef OPENSSL_1_1_0
-     BN_free(e);
-     e = NULL;
--#endif /* OPENSSL_1_1_0 */
-   }
-   return key;
- }
-diff --git a/pith/smkeys.h b/pith/smkeys.h
-index e37eea3..a6c143b 100644
---- a/pith/smkeys.h
-+++ b/pith/smkeys.h
-@@ -32,6 +32,8 @@
- #include <openssl/safestack.h>
- #include <openssl/conf.h>
- #include <openssl/x509v3.h>
-+#include <openssl/bn.h>
-+#include <openssl/rsa.h>
- #ifndef OPENSSL_1_1_0
- #define X509_get0_notBefore(x) ((x) && (x)->cert_info                   \
-@@ -47,9 +49,6 @@
-                                 ? (x)->cert_info->validity->notAfter  \
-                                 : NULL)
- #define X509_REQ_get0_pubkey(x) (X509_REQ_get_pubkey((x)))
--#else
--#include <openssl/rsa.h>
--#include <openssl/bn.h>
- #endif /* OPENSSL_1_1_0 */
- #define EMAILADDRLEADER "emailAddress="