doc: Make checkpatch ignore rst files
authorPaul Beesley <paul.beesley@arm.com>
Thu, 7 Mar 2019 16:42:31 +0000 (16:42 +0000)
committerPaul Beesley <paul.beesley@arm.com>
Wed, 22 May 2019 10:23:06 +0000 (11:23 +0100)
Previously checkpatch was invoked with options to make it ignore
Markdown (md) files as this was the dominant format for TF-A
documents. Now that rst is being used everywhere this option needs
updating.

Change-Id: I59b5a0bcc45d2386df4f880b8d333baef0bbee77
Signed-off-by: Paul Beesley <paul.beesley@arm.com>
Makefile

index 16b4ccc4277685044b6049380de6b4fb837076ae..976f514dda3200a220841572fff36fa70c0fc207 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -55,7 +55,7 @@ ROOT_DIRS_TO_CHECK    :=      $(sort $(filter-out                     \
                                        lib                             \
                                        include                         \
                                        docs                            \
-                                       %.md,                           \
+                                       %.rst,                          \
                                        $(wildcard *)))
 CHECK_PATHS            :=      ${ROOT_DIRS_TO_CHECK}                   \
                                ${INC_DIRS_TO_CHECK}                    \
@@ -815,7 +815,7 @@ realclean distclean:
 checkcodebase:         locate-checkpatch
        @echo "  CHECKING STYLE"
        @if test -d .git ; then                                         \
-               git ls-files | grep -E -v 'libfdt|libc|docs|\.md' |     \
+               git ls-files | grep -E -v 'libfdt|libc|docs|\.rst' |    \
                while read GIT_FILE ;                                   \
                do ${CHECKPATCH} ${CHECKCODE_ARGS} -f $$GIT_FILE ;      \
                done ;                                                  \
@@ -825,7 +825,7 @@ checkcodebase:              locate-checkpatch
                 -not -iwholename "*libfdt*"                            \
                 -not -iwholename "*libc*"                              \
                 -not -iwholename "*docs*"                              \
-                -not -iwholename "*.md"                                \
+                -not -iwholename "*.rst"                               \
                 -exec ${CHECKPATCH} ${CHECKCODE_ARGS} -f {} \; ;       \
        fi