boost: Update host libraries 10059/head
authorRosen Penev <rosenp@gmail.com>
Mon, 23 Sep 2019 18:11:06 +0000 (11:11 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 23 Sep 2019 18:29:52 +0000 (11:29 -0700)
It seems newer versions of fbthrift require more libraries.

Also added AR7, RB532, and Lantiq ASE to fiber exclusion.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/boost/Makefile

index dc7fab029797950c9af6d307572657de353ddb6e..1c8e4fe5cb096da111ad0d925bbbd073a85831bc 100644 (file)
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=boost
 PKG_VERSION:=1.71.0
 PKG_SOURCE_VERSION:=1_71_0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
@@ -130,7 +130,7 @@ define Package/boost/config
 
        config boost-fiber-exclude
                bool
-               default y if (TARGET_brcm47xx_generic || TARGET_brcm47xx_legacy || mips32 || mips64 || boost-coroutine-exclude)
+               default y if (TARGET_ar7 || TARGET_brcm47xx_generic || TARGET_brcm47xx_legacy || TARGET_lantiq_ase || TARGET_rb532 || mips32 || mips64 || boost-coroutine-exclude)
                default n
 
        menu "Select Boost Options"
@@ -367,7 +367,7 @@ define Host/Compile
 
        ( cd $(HOST_BUILD_DIR) ; \
                ./bootstrap.sh --prefix=$(STAGING_DIR_HOSTPKG) \
-                       --with-libraries=atomic,chrono,date_time,filesystem,headers,thread,system ;\
+                       --with-libraries=atomic,context,date_time,filesystem,headers,program_options,regex,system,thread ;\
                ./b2 --ignore-site-config install )
 endef