luci.mk: move indexcache delete into postinst 3400/head
authorFlorian Eckert <fe@dev.tdt.de>
Tue, 10 Dec 2019 12:28:13 +0000 (13:28 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Tue, 10 Dec 2019 12:28:19 +0000 (13:28 +0100)
Almost every uci-defaults script for ucitrack execute after the uci
commands the following line '/tmp/luci-indexcache'.
So that we don't always write the same thing, we now do this in
postinst.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
luci.mk

diff --git a/luci.mk b/luci.mk
index d8fa029511ed6ac6be425b5c097489facbfe84d1..e6c48ccc669909e8e625c1df271ce2ebb561c731 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -218,6 +218,7 @@ ifneq ($(LUCI_DEFAULTS),)
 define Package/$(PKG_NAME)/postinst
 [ -n "$${IPKG_INSTROOT}" ] || {$(foreach script,$(LUCI_DEFAULTS),
        (. /etc/uci-defaults/$(script)) && rm -f /etc/uci-defaults/$(script))
+       rm -f /tmp/luci-indexcache
        exit 0
 }
 endef