dump1090: remove interactive options, hardcode quiet and add respawn config.
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Mon, 27 Oct 2014 19:56:14 +0000 (20:56 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Mon, 27 Oct 2014 19:56:14 +0000 (20:56 +0100)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
utils/dump1090/Makefile
utils/dump1090/files/dump1090.config
utils/dump1090/files/dump1090.init

index 15a680b66b087e3d81812942b8d2e7cd50dd129f..51fcc9d73f2bef8cb87f62cee5e93d9f2ce54767 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dump1090
-PKG_VERSION:=2014-10-25
+PKG_VERSION:=2014-10-27
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
index 2fa76836d41d3e3f2f09427604781e63632e6612..2267798a96c61fae572410cc0b2ccb1312500953 100644 (file)
@@ -1,14 +1,11 @@
 config dump1090 main
        option disabled '1'
+       option respawn '1'
        option device_index ''
        option gain ''
        option enable_agc '0'
        option freq ''
        option ifile ''
-       option interactive '0'
-       option interactive_rows ''
-       option interactive_ttl ''
-       option interactive_rtl1090 '0'
        option raw '0'
        option net '1'
        option modeac '0'
@@ -38,5 +35,4 @@ config dump1090 main
        option metric '0'
        option snip ''
        option debug ''
-       option quiet '1'
        option ppm ''
index 816887a1f658c7310ccc705128dbbb7b1e782d6d..c7c2161e288b8d1d139b8fc8b23251c45836af22 100644 (file)
@@ -29,23 +29,21 @@ append_bool() {
 
 start_instance() {
        local cfg="$1"
+       local aux
 
-       config_get_bool disabled "$cfg" 'disabled' '0'
-       [ "$disabled" = 1 ] && return 1
+       config_get_bool aux "$cfg" 'disabled' '0'
+       [ "$aux" = 1 ] && return 1
 
        procd_open_instance
 
        procd_set_param command /usr/bin/dump1090
+       procd_append_param command "--quiet"
 
        append_arg "$cfg" device_index "--device-index"
        append_arg "$cfg" gain "--gain"
        append_bool "$cfg" enable_agc "--enable-agc"
        append_arg "$cfg" freq "--freq"
        append_arg "$cfg" ifile "--ifile"
-       append_bool "$cfg" interactive "--interactive"
-       append_arg "$cfg" interactive_rows "--interactive-rows"
-       append_arg "$cfg" interactive_ttl "--interactive-ttl"
-       append_bool "$cfg" interactive_rtl1090 "--interactive-rtl1090"
        append_bool "$cfg" raw "--raw"
        append_bool "$cfg" net "--net"
        append_bool "$cfg" modeac "--modeac"
@@ -75,9 +73,11 @@ start_instance() {
        append_bool "$cfg" metric "--metric"
        append_arg "$cfg" snip "--snip"
        append_arg "$cfg" debug "--debug"
-       append_bool "$cfg" quiet "--quiet"
        append_arg "$cfg" ppm "--ppm"
 
+       config_get_bool aux "$cfg" 'respawn' '0'
+       [ "$aux" = 1 ] && procd_set_param respawn
+
        procd_close_instance
 }