Workaround for Neoverse N1 erratum 1165347
authorlauwal01 <lauren.wehrmeister@arm.com>
Mon, 24 Jun 2019 16:32:40 +0000 (11:32 -0500)
committerlauwal01 <lauren.wehrmeister@arm.com>
Tue, 2 Jul 2019 14:15:15 +0000 (09:15 -0500)
Neoverse N1 erratum 1165347 is a Cat B erratum [1],
present in older revisions of the Neoverse N1 processor core.
The workaround is to set two bits in the implementation defined
CPUACTLR2_EL1 system register.

[1] http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.pjdoc-466751330-10325/index.html

Change-Id: I163d0ea00578245c1323d2340314cdc3088c450d
Signed-off-by: Lauren Wehrmeister <lauren.wehrmeister@arm.com>
docs/design/cpu-specific-build-macros.rst
include/lib/cpus/aarch64/neoverse_n1.h
lib/cpus/aarch64/neoverse_n1.S
lib/cpus/cpu-ops.mk

index 01ee416257580ae9eff1ed7dfd9bd5657eca1d18..fd99d8e90f4c062c7733cb274af61f011564e686 100644 (file)
@@ -234,6 +234,9 @@ For Neoverse N1, the following errata build flags are defined :
 -  ``ERRATA_N1_1130799``: This applies errata 1130799 workaround to Neoverse-N1
    CPU. This needs to be enabled only for revision <= r2p0 of the CPU.
 
+-  ``ERRATA_N1_1165347``: This applies errata 1165347 workaround to Neoverse-N1
+   CPU. This needs to be enabled only for revision <= r2p0 of the CPU.
+
 -  ``ERRATA_N1_1315703``: This applies errata 1315703 workaround to Neoverse-N1
    CPU. This needs to be enabled only for revision <= r3p0 of the CPU.
 
index 9042d7031db87dcb289be16b25ba13348ced9d52..7950cd220b5fc2fca1e678397453b50dab90c0c9 100644 (file)
@@ -39,7 +39,9 @@
 
 #define NEOVERSE_N1_CPUACTLR2_EL1      S3_0_C15_C1_1
 
+#define NEOVERSE_N1_CPUACTLR2_EL1_BIT_0                (ULL(1) << 0)
 #define NEOVERSE_N1_CPUACTLR2_EL1_BIT_2                (ULL(1) << 2)
+#define NEOVERSE_N1_CPUACTLR2_EL1_BIT_15       (ULL(1) << 15)
 #define NEOVERSE_N1_CPUACTLR2_EL1_BIT_16       (ULL(1) << 16)
 #define NEOVERSE_N1_CPUACTLR2_EL1_BIT_59       (ULL(1) << 59)
 
index 31708a4e6372ca1ddf14e519056a4cbc58796643..a8ffa254691eb0d5bdd567893314f2d386f601c6 100644 (file)
@@ -129,6 +129,34 @@ func check_errata_1130799
        b       cpu_rev_var_ls
 endfunc check_errata_1130799
 
+/* --------------------------------------------------
+ * Errata Workaround for Neoverse N1 Errata #1165347
+ * This applies to revision <=r2p0 of Neoverse N1.
+ * Inputs:
+ * x0: variant[4:7] and revision[0:3] of current cpu.
+ * Shall clobber: x0-x17
+ * --------------------------------------------------
+ */
+func errata_n1_1165347_wa
+       /* Compare x0 against revision r2p0 */
+       mov     x17, x30
+       bl      check_errata_1165347
+       cbz     x0, 1f
+       mrs     x1, NEOVERSE_N1_CPUACTLR2_EL1
+       orr     x1, x1, NEOVERSE_N1_CPUACTLR2_EL1_BIT_0
+       orr     x1, x1, NEOVERSE_N1_CPUACTLR2_EL1_BIT_15
+       msr     NEOVERSE_N1_CPUACTLR2_EL1, x1
+       isb
+1:
+       ret     x17
+endfunc errata_n1_1165347_wa
+
+func check_errata_1165347
+       /* Applies to <=r2p0 */
+       mov     x1, #0x20
+       b       cpu_rev_var_ls
+endfunc check_errata_1165347
+
 /* --------------------------------------------------
  * Errata Workaround for Neoverse N1 Erratum 1315703.
  * This applies to revision <= r3p0 of Neoverse N1.
@@ -187,6 +215,11 @@ func neoverse_n1_reset_func
        bl      errata_n1_1130799_wa
 #endif
 
+#if ERRATA_N1_1165347
+       mov     x0, x18
+       bl      errata_n1_1165347_wa
+#endif
+
 #if ERRATA_N1_1315703
        mov     x0, x18
        bl      errata_n1_1315703_wa
@@ -251,6 +284,7 @@ func neoverse_n1_errata_report
        report_errata ERRATA_N1_1043202, neoverse_n1, 1043202
        report_errata ERRATA_N1_1073348, neoverse_n1, 1073348
        report_errata ERRATA_N1_1130799, neoverse_n1, 1130799
+       report_errata ERRATA_N1_1165347, neoverse_n1, 1165347
        report_errata ERRATA_N1_1315703, neoverse_n1, 1315703
        report_errata ERRATA_DSU_936184, neoverse_n1, dsu_936184
 
index 676667b6365514e299e8cdae58f44a39e8fcae92..faaf1203bf6226fec066c708dced97801ffb3140 100644 (file)
@@ -246,6 +246,10 @@ ERRATA_N1_1073348  ?=0
 # only to revision <= r2p0 of the Neoverse N1 cpu.
 ERRATA_N1_1130799      ?=0
 
+# Flag to apply erratum 1165347 workaround during reset. This erratum applies
+# only to revision <= r2p0 of the Neoverse N1 cpu.
+ERRATA_N1_1165347      ?=0
+
 # Flag to apply erratum 1315703 workaround during reset. This erratum applies
 # to revisions before r3p1 of the Neoverse N1 cpu.
 ERRATA_N1_1315703      ?=1
@@ -447,6 +451,10 @@ $(eval $(call add_define,ERRATA_N1_1073348))
 $(eval $(call assert_boolean,ERRATA_N1_1130799))
 $(eval $(call add_define,ERRATA_N1_1130799))
 
+# Process ERRATA_N1_1165347 flag
+$(eval $(call assert_boolean,ERRATA_N1_1165347))
+$(eval $(call add_define,ERRATA_N1_1165347))
+
 # Process ERRATA_N1_1315703 flag
 $(eval $(call assert_boolean,ERRATA_N1_1315703))
 $(eval $(call add_define,ERRATA_N1_1315703))