[packages] keepalived: force enabling of VRRP functionality, fix path to config file...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 9 May 2009 22:12:20 +0000 (22:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 9 May 2009 22:12:20 +0000 (22:12 +0000)
SVN-Revision: 15746

net/keepalived/Makefile
net/keepalived/files/keepalived.init

index a840e5b5a525fb12f1d194866489efbf9925c158..bcf312bd8c7c254a08c1e996136d6886f79fc141 100644 (file)
@@ -47,7 +47,8 @@ CONFIGURE_ARGS+= \
        --with-kernel-dir="$(LINUX_DIR)" \
 
 CONFIGURE_VARS+= \
-       ac_cv_file_$(call acvar,$(LINUX_DIR)/net/core/link_watch.c)=no \
+       ac_cv_file_$(call acvar,$(LINUX_DIR)/net/core/link_watch.c)=yes \
+       VRRP_SUPPORT=yes \
 
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
index c98984bcf2337e3f659f2d21e0effa37fe30b3c8..723947cc3ff57860124c2ac9b34fe3b5838eb9b5 100644 (file)
@@ -4,7 +4,7 @@
 START=70
 
 start() {
-        [ -f /etc/keepalived/keepalived ] && /usr/sbin/keepalived
+        [ -f /etc/keepalived/keepalived.conf ] && /usr/sbin/keepalived
 }
 
 stop() {