Merge pull request #3577 from MikePetullo/eventlog
authorStijn Tintel <stijn+github@linux-ipv6.be>
Fri, 6 Jan 2017 19:49:02 +0000 (20:49 +0100)
committerGitHub <noreply@github.com>
Fri, 6 Jan 2017 19:49:02 +0000 (20:49 +0100)
Copy eventlog package from old repository and revise

lang/python/Makefile
lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch [new file with mode: 0644]
net/adblock/Makefile
net/adblock/files/adblock.sh
utils/grep/Makefile
utils/haveged/Makefile

index b803b8c65027dab8d9ab1e9f6ee2c11835682987..fbdd06cd5beae9b77e0cbf576b9c76505a3e65fa 100644 (file)
@@ -12,7 +12,7 @@ include ./files/python-version.mk
 
 PKG_NAME:=python
 PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
diff --git a/lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch b/lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch
new file mode 100644 (file)
index 0000000..1a442e0
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -859,7 +859,7 @@ class PyBuildExt(build_ext):
+         min_openssl_ver = 0x00907000
+         have_any_openssl = ssl_incs is not None and ssl_libs is not None
+-        have_usable_openssl = (have_any_openssl and
++        have_usable_openssl = cross_compiling and (have_any_openssl and
+                                openssl_ver >= min_openssl_ver)
+         if have_any_openssl:
index de4844ba28cac259985635a86c5601544c028fed..20b141931d5ecad43707f6f9c159ab05ef5d01d4 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
-PKG_VERSION:=2.1.0
+PKG_VERSION:=2.1.1
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
index 95b943483ceb66f7f14e5ebe1d5ae9795539db51..771857fc06c2ac507df76acf1011229ce394b72a 100755 (executable)
@@ -10,7 +10,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="2.1.0"
+adb_ver="2.1.1"
 adb_enabled=1
 adb_debug=0
 adb_whitelist="/etc/adblock/adblock.whitelist"
@@ -251,20 +251,20 @@ f_query()
 
     if [ -z "${dns_active}" ]
     then
-         printf "%s\n" ":: no active block lists found, please start adblock first"
+         printf "%s\n" "::: no active block lists found, please start adblock first"
     elif [ -z "${domain}" ] || [ "${domain}" = "${tld}" ]
     then
-        printf "%s\n" ":: invalid domain input, please submit a specific (sub-)domain, i.e. 'www.abc.xyz'"
+        printf "%s\n" "::: invalid domain input, please submit a specific (sub-)domain, i.e. 'www.abc.xyz'"
     else
+        cd "${adb_dnsdir}"
         while [ "${domain}" != "${tld}" ]
         do
             search="${domain//./\.}"
-            result="$(grep -Hm 1 "[/\.]${search}/" "${adb_dnsdir}/${adb_dnsprefix}"* | awk -F ':|/' '{print "   "$4"\t: "$6}')"
-            cnt="$(grep -hc "[/\.]${search}/" "${adb_dnsdir}/${adb_dnsprefix}"* | awk '{sum += $1} END {printf sum}')"
-            printf "%s\n" ":: distinct results for domain '${domain}' (overall ${cnt})"
+            result="$(grep -Hm1 "[/\"\.]${search}[/\"]" "${adb_dnsprefix}"* | awk -F ':|=|/|\"' '{printf(" %-20s : %s\n",$1,$4)}')"
+            printf "%s\n" "::: distinct results for domain '${domain}'"
             if [ -z "${result}" ]
             then
-                printf "%s\n" "   no matches in active block lists"
+                printf "%s\n" " no match"
             else
                 printf "%s\n" "${result}"
             fi
index 5273231dc9701ddb24935c952544b3b59e549e68..6ee0697c6217cf92989c0034528680b4afc6a080 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=grep
-PKG_VERSION:=2.25
+PKG_VERSION:=2.26
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/grep
-PKG_MD5SUM:=04e96b0e6f0fe6a180ae62c88fcd0af6
+PKG_MD5SUM:=afdd61c7221434722671baf002ac9267
 
 PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
index 9cd7b7883f8931b0a4b81faece2bd564cf921c74..c5adad734b9c6a8ad2e3402b2a955a71c689da1e 100644 (file)
@@ -12,8 +12,8 @@ PKG_VERSION:=1.9.1
 PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.issihosts.com/$(PKG_NAME) \
-       http://pkgs.fedoraproject.org/repo/pkgs/haveged/haveged-1.9.1.tar.gz/015ff58cd10607db0e0de60aeca2f5f8/
+PKG_SOURCE_URL:=@SF/haveged \
+               http://www.issihosts.com/$(PKG_NAME)
 PKG_MD5SUM:=9c2363ed9542a6784ff08e247182137e71f2ddb79e8e6c1ac4ad50d21ced3715
 PKG_LICENSE:=GPLv3