ibrdtn-tools: fix compilation with GCC11
authorRosen Penev <rosenp@gmail.com>
Wed, 7 Jul 2021 20:37:55 +0000 (13:37 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 11 Jul 2021 07:23:55 +0000 (00:23 -0700)
throw() is not supported with C++17.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/ibrdtn-tools/Makefile

index f717f277a9af5b927020bc5edd2eb5fa8bc408b1..8286b9bb3f95a2c1f860f1bfc51e91bfd37b64da 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ibrdtn-tools
 PKG_VERSION:=1.0.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
@@ -36,6 +36,8 @@ endef
 CONFIGURE_ARGS += \
        --without-libdaemon
 
+TARGET_CXXFLAGS += -std=c++11
+
 define Package/ibrdtn-tools/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtnping $(1)/usr/bin/dtnping